php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57580 Wrong LDFLAGS definition in config.m4
Submitted: 2007-03-19 09:45 UTC Modified: 2007-05-02 23:46 UTC
From: chtekk at gentoo dot org Assigned:
Status: Closed Package: mcve (PECL)
PHP Version: 5.2.1 OS: Gentoo Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chtekk at gentoo dot org
New email:
PHP Version: OS:

 

 [2007-03-19 09:45 UTC] chtekk at gentoo dot org
Description:
------------
During some experiments, where I tweaked the LDFLAGS a bit, I noticed problems with the pecl mcve module 5.2.2, but not 5.2.0, it looked like the LDFLAGS defined were just ignored, and the reason is simple, the following patch fixes it:

--- config.m4   2007-03-19 14:10:07.000000000 +0100
+++ config.m4   2007-03-19 14:10:50.000000000 +0100
@@ -166,7 +166,6 @@
     LIBM_CFLAGS="$LIBM_CFLAGS -I$krb5headers"
   fi
   CFLAGS="$CFLAGS $LIBM_CFLAGS"
-  LDFLAGS="$CFLAGS $LIBM_LDFLAGS"
 
   PHP_NEW_EXTENSION(mcve, mcve.c, $ext_shared)
   PHP_SUBST(MCVE_SHARED_LIBADD)

I can't really understand why you redefine LDFLAGS, since LIBM_LDFLAGS is anyway never defined, and doing it using CFLAGS is incorrect, if you really want to redefine LDFLAGS it should be LDFLAGS="$LDFLAGS $LIBM_LDFLAGS", but since LIBM_LDFLAGS is never defined, I think you can completely omit that part, you probably only really want to intervene on CFLAGS.
Best regards, CHTEKK.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-02 23:46 UTC] edin at krug dot dk
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

LIBM_LDFLAGS is indeed not used, but I just fixed the type in case it gets used.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Tue Sep 25 03:01:25 2018 UTC