php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57504 nulls lost on clone()
Submitted: 2007-01-31 11:47 UTC Modified: 2007-04-26 11:34 UTC
From: mfp@php.net Assigned: tuscany (profile)
Status: Closed Package: SCA_SDO (PECL)
PHP Version: 5.1.6 OS: WinXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
26 - 22 = ?
Subscribe to this entry?

 
 [2007-01-31 11:47 UTC] mfp@php.net
Description:
------------
I assign nulls to properties of an SDO then clone it. The nulls do not get into the cloned object. 

It does not matter by the way whether or not I have nillable="true" in the schema. 

Reproduce code:
---------------
<?php

$xsd = <<<EOF
<?xml version="1.0" encoding="UTF-8"?>
<schema xmlns="http://www.w3.org/2001/XMLSchema"
        targetNamespace="PersonNamespace"
        xmlns:AuthorNS="PersonNamespace">
  <complexType name="personType">
    <sequence>
      <element name="name" type="string"/>
      <element name="dob" type="string"/>
      <element name="pob" type="string"/>
    </sequence>
  </complexType>
</schema>
EOF;

file_put_contents('person.xsd',$xsd);

$xmldas = SDO_DAS_XML::create('person.xsd');

$person = $xmldas->createDataObject('PersonNamespace','personType');

$person->name = "William Shakespeare'";
$person->dob = null;
$person->pob = null;

$person2 = clone($person);
print($person);
echo "\n";
print($person2);

?>

Expected result:
----------------
I want to see nulls in dob abd pob for $person2. 

Actual result:
--------------
object(SDO_DataObject)#3 (3) {name=>"William Shakespeare'"; dob=>NULL; pob=>NULL}
object(SDO_DataObject)#4 (3) {name=>"William Shakespeare'"; dob; pob}

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-26 11:34 UTC] cem@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

Fix will be in next release RSN
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jan 26 09:03:33 2022 UTC