php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57487 Windows Crash on Exceptions
Submitted: 2007-01-20 09:21 UTC Modified: 2017-04-01 21:54 UTC
From: jean-pascal at online dot de Assigned:
Status: Wont fix Package: WinBinder (PECL)
PHP Version: 5.1.0 OS: WIN32
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jean-pascal at online dot de
New email:
PHP Version: OS:

 

 [2007-01-20 09:21 UTC] jean-pascal at online dot de
Description:
------------
Hi Folks,

first I just want to say that you did good work with WinBinder! Respect!

So, but there's still a little Problem. When i gonna try
to throw an exception like here:

try {
    // creating windows normal way....

    wb_main_loop();
}
catch(Exception $e){
    // message box for $e->getMessage() here...
}

...the CLI Windows process gonna crash. 
Do you think that you can find a fix for this? Or is my
Code the Problem?

Greets,
Jean.

Reproduce code:
---------------
Heres the Code without Includes (theres no php error for sure)

### MAIN BLOCK
try {
	// hauptfenster erzeugen.
	freelancer_wb_create_window(null, 'main', 'FreeLancer 0.2', ResizableWindow, null, null, 800, 400);
	
	// main loop
	wb_main_loop();
}
catch(Exception $e){
	wb_message_box(null, $e->getMessage(), "FreeLancer Ausnahme", WBC_WARNING);
	file_put_contents(FREELANCER_DIR_ROOT . 'last_crash.txt', $e);
	//exit(1);
}

Expected result:
----------------
An WIN32 Crash (exception)

Actual result:
--------------
Ill really tried to find a way to copy the backtrace, but i failed. When you know a way to copy that text let me know it!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:54 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:54 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2010, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 24 12:01:24 2020 UTC