php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5741 --with-mysql=/usr/include/mysql (or any other combination) fails on ./configure
Submitted: 2000-07-23 00:58 UTC Modified: 2000-07-24 01:24 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: bughuntr at ctelcom dot net Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.1pl2 OS: RedHat 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bughuntr at ctelcom dot net
New email:
PHP Version: OS:

 

 [2000-07-23 00:58 UTC] bughuntr at ctelcom dot net
latest release downloaded 10minutes ago

./configure --with-mysql --with-apxs=/usr/sbin/apxs 
works, but script complains that other server modules won't work, and I should configure with the route to mysql.  I have installed Mysql-devel package, along with clients, server, libraries.

./configure --with-mysql=/usr/include/mysql indicates that no header files can be found (it does not say which cannot be found).  the mysql header files are there.  Every one of them.  even if I use /usr/include/mysql/ it still fails.

Either the error message from the script should be more verbose (which header file it was looking for), or the /path/to/mysql should indicate what directory you really are looking for. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-24 01:24 UTC] rasmus at cvs dot php dot net
./configure --with-mysql=/usr

This is explained adequately in the INSTALL file.  It needs to find both header and library files, and since there are no library files anywhere under /usr/include, you have to provide the lowest-level path under which both the .a or .so and the .h files exist.  And in your case that would be /usr
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 16 13:05:43 2022 UTC