php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5738 arrays doesn't keep track of number of objects in it.
Submitted: 2000-07-22 20:27 UTC Modified: 2000-07-22 21:16 UTC
From: rogjo501 at student dot liu dot se Assigned:
Status: Closed Package: Other
PHP Version: 4.0.1pl2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rogjo501 at student dot liu dot se
New email:
PHP Version: OS:

 

 [2000-07-22 20:27 UTC] rogjo501 at student dot liu dot se
When adding class-objects to an array the array doesn't seem to keep track of how many it has.

Like if I add 10 objects to the array and then do a 
count(array);

It says 1 item.
This is a bit annoying since I can't use the sorting functions on it either.

// Roger Johannesson

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-22 21:16 UTC] mrobinso at cvs dot php dot net
Closed per user request.
Will reopen if reproduceable.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 23:03:43 2022 UTC