php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #57364 Cannot use external libzip
Submitted: 2006-11-09 15:01 UTC Modified: 2006-11-09 20:01 UTC
From: jdolecek at NetBSD dot org Assigned: pajoye (profile)
Status: Duplicate Package: zip (PECL)
PHP Version: Irrelevant OS: NetBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jdolecek at NetBSD dot org
New email:
PHP Version: OS:

 

 [2006-11-09 15:01 UTC] jdolecek at NetBSD dot org
Description:
------------
Zip package doesn't support building against non-bundled libzip. This is inconvenient for distributions which ship binary packages, since the shared libzip cannot be used.

Please add a way to choose whether to build agains already installed libzip or the bundled version.

Reproduce code:
---------------
N/A - build process inspection


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-09 20:01 UTC] pierre dot php at gmail dot com
You cannot and should not use an external lib.

See #39388 in bugs.php.net
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 14:01:24 2020 UTC