php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57361 Apache crashing every other page
Submitted: 2006-11-08 17:34 UTC Modified: 2010-11-03 19:04 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: brice dot joly at free dot fr Assigned:
Status: No Feedback Package: APC (PECL)
PHP Version: 5.2.0 RC4 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: brice dot joly at free dot fr
New email:
PHP Version: OS:

 

 [2006-11-08 17:34 UTC] brice dot joly at free dot fr
Description:
------------
Windows XP SP2, Apache 2.0.58, PHP 5.2.0, php_apc.dll 5.2.0.0 (RC3-dev).

Apache starts normally, apc.php runs as expected. Visit a page: apc.php shows cached files as expected. Visit another page: crashes Apache, which instantly restarts. Seems like it crashes every other page. When APC is not loaded, Apache never crashes.

No error in the PHP error log (E_ALL|E_STRICT), nor in the Apache one (except the usual stop/start messages).

Note: before upgrading to 5.2.0 I was running 5.1.6 and APC never crashed Apache while running, yet it crashed Apache when I was manually shutting it down/restarting (twice during the stop process).

APC configuration:
[APC]
apc.enabled        = 1
apc.shm_segments   = 1
apc.optimization   = 0
apc.shm_size       = 128
apc.ttl            = 7200
apc.user_ttl       = 7200
apc.num_files_hint = 768
apc.enable_cli     = 0

Windows Application Error report:
[...]
Description :
Application d?faillante Apache.exe, version 2.0.58.200, module d?faillant php5ts.dll, version 5.2.0.0, adresse de d?faillance 0x00097d80.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-30 02:03 UTC] danstevens at yahoo dot com
I'm having this exact same issue, except I'm using IIS & Windows 2003. With APC enabled, the first page requested will load, upon refreshing the page, IIS crashes. It seems the 5.2.x version of APC is flawed.
 [2007-03-07 07:57 UTC] j dot dadd at improvision dot com
I too am having the same issue.

Win 2K server, IIS 5.0, PHP 5.2.1

Enable php_apc.dll within the php.ini and the second page loaded brings up the dreaded "access violation" error :(

Remove the php_apc.dll from the ini and restart the web service and the site works perfectly again.
 [2007-03-07 10:07 UTC] gopalv82 at yahoo dot com
Is this bug present in 3.0.13 release as well ?
 [2009-02-13 14:38 UTC] sagarchand at gmail dot com
Does any body found a solution for this? Man..I've been hitting on this for ages now but in vain. Even the pecl4win site is down for upgradation.

:(
 [2009-03-02 00:30 UTC] shire@php.net
Have you tried one of the temporary builds from here?:
http://downloads.php.net/pierre/
 [2009-09-21 02:30 UTC] kalle@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

Any chance of trying to provide a backtrace to see where it crashes? Aswell as trying with the APC 3.1 branch and or the latest 5.2/5.3 stable PHP branches?
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 20 23:01:25 2020 UTC