php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57282 build fails --without-http-zlib-compression
Submitted: 2006-10-06 06:33 UTC Modified: 2007-02-15 09:38 UTC
From: zaa at zaa dot pp dot ru Assigned: mike (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: 5.1.6 OS: FreeBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: zaa at zaa dot pp dot ru
New email:
PHP Version: OS:

 

 [2006-10-06 06:33 UTC] zaa at zaa dot pp dot ru
Description:
------------
wave:...up/pecl_http-1.3.1# php -v
PHP 5.1.6 (cli) (built: Sep  6 2006 11:35:36)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
    with Zend Extension Manager v1.0.10, Copyright (c) 2003-2006, by Zend Technologies
    with Zend Optimizer v3.0.1, Copyright (c) 1998-2006, by Zend Technologies

wave:...up/pecl_http-1.3.1# uname -mrs
FreeBSD 6.1-STABLE i386
wave:...up/pecl_http-1.3.1# phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20050922
Zend Extension Api No:   220051025

wave:...up/pecl_http-1.3.1# gcc -v
Using built-in specs.
Configured with: FreeBSD/i386 system compiler
Thread model: posix
gcc version 3.4.4 [FreeBSD] 20050518

wave:...up/pecl_http-1.3.1# ./configure --enable-http --with-php-config=/usr/local/bin/php-config --with-http-curl-requests=/usr/local --with-http-magic-mime=/usr --without-http-zlib-compression --prefix=/usr/local

...
checking for curl version >= 7.12.3... 7.15.5
...

wave:...up/pecl_http-1.3.1# make
...
/usr/local/bin/bash /u/zaa/up/pecl_http-1.3.1/libtool --mode=compile gcc  -I. -I/u/zaa/up/pecl_http-1.3.1 -DPHP_ATOM_INC -I/u/zaa/up/pecl_http-1.3.1/include -I/u/zaa/up/pecl_http-1.3.1/main -I/u/zaa/up/pecl_http-1.3.1 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include -I/usr/local/include/php/ext/hash  -DHAVE_CONFIG_H  -g -O2   -c /u/zaa/up/pecl_http-1.3.1/http_send_api.c -o http_send_api.lo
 gcc -I. -I/u/zaa/up/pecl_http-1.3.1 -DPHP_ATOM_INC -I/u/zaa/up/pecl_http-1.3.1/include -I/u/zaa/up/pecl_http-1.3.1/main -I/u/zaa/up/pecl_http-1.3.1 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include -I/usr/local/include/php/ext/hash -DHAVE_CONFIG_H -g -O2 -c /u/zaa/up/pecl_http-1.3.1/http_send_api.c  -fPIC -DPIC -o .libs/http_send_api.o
/u/zaa/up/pecl_http-1.3.1/http_send_api.c: In function `_http_send_response_data_plain':
/u/zaa/up/pecl_http-1.3.1/http_send_api.c:68: error: `http_encoding_stream' undeclared (first use in this function)
/u/zaa/up/pecl_http-1.3.1/http_send_api.c:68: error: (Each undeclared identifier is reported only once
/u/zaa/up/pecl_http-1.3.1/http_send_api.c:68: error: for each function it appears in.)
/u/zaa/up/pecl_http-1.3.1/http_send_api.c:68: error: syntax error before ')' token
*** Error code 1


The same error can be reproduced on FreeBSD 4.11-STABLE with gcc 2.95.4


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-07 07:51 UTC] mike@php.net
Changed summary.

M<y I ask why you build pecl_http without zlib support?
 [2006-10-07 13:21 UTC] zaa at zaa dot pp dot ru
I've just tried to compile the extension with zlib support, but got the same error.
I built it without zlib support, because FreeBSD 4.11-STABLE is shipped with old zlib library which can not be used by this extension.
 [2006-10-07 13:24 UTC] zaa at zaa dot pp dot ru
Update ... 
Sorry for confusion. 
The extension was compiled on FreeBSD 6.2 when the zlib support has been enabled. Is this a requirement now?
 [2006-10-08 04:29 UTC] mike@php.net
> I built it without zlib support, because FreeBSD 
> 4.11-STABLE is shipped with old zlib library which 
> can not be used by this extension.

Oh, I see.

> I've just tried to compile the extension with zlib 
> support, but got the same error.

This is odd :)

> The extension was compiled on FreeBSD 6.2 when the 
> zlib support has been enabled. Is this a requirement now?

No, this bug should be fixed in CVS.

I'd appreciate if you could confirm that it builds fine now on FBSD4 without zlib support and FBSD6 with zlib support. I'll release 1.3.2 then.

Thank you very much!

Just one thing more... May I contact you prior each release so that we can make sure that a version which is about to be released compiles fine on your systems?
 [2006-10-09 10:01 UTC] zaa at zaa dot pp dot ru
>I'd appreciate if you could confirm that it builds fine now on FBSD4
>without zlib support and FBSD6 with zlib support. I'll release 1.3.2
>then.

Latest package version from CVS was built successfully on FreeBSD 4.11 and 5.5. 

>Just one thing more... May I contact you prior each release so that we
> can make sure that a version which is about to be released compiles fine
> on your systems?

Yes. Sure.

Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 06:03:37 2021 UTC