php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57273 package.xml package name need not match case and must
Submitted: 2006-10-03 12:13 UTC Modified: 2006-10-31 16:22 UTC
From: alex dot brims at gmail dot com Assigned: cellog (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: 4_4 CVS-2006-10-03 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alex dot brims at gmail dot com
New email:
PHP Version: OS:

 

 [2006-10-03 12:13 UTC] alex dot brims at gmail dot com
Description:
------------
MP3_ID - all releases return not found


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-03 15:57 UTC] mj@php.net
Confirmed; need to investigate.  For now, one can use the old link format:

http://pear.php.net/get/MP3_ID
 [2006-10-03 16:13 UTC] mj@php.net
For MP3_Id this has been fixed.

But the general problem persists:  The package was registered as MP3_ID on pear.php.net, while its name in package.xml is MP3_Id ('D' != 'd').  In the old download infrastructure this was no problem because it works case-insensitive.  The new download interface is case-sensitive.

This report will remain open and assigned until I get around to properly fix it.
 [2006-10-31 16:18 UTC] cellog@php.net
this can be fixed in release-upload.php
 [2006-10-31 16:22 UTC] cellog@php.net
This bug has been fixed in CVS.

If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET).

If this was a problem with the pear.php.net website, the change should be live shortly.

Otherwise, the fix will appear in the package's next release.

Thank you for the report and for helping us make PEAR better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 18:01:23 2020 UTC