php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57272 Compile problems
Submitted: 2006-10-02 15:49 UTC Modified: 2006-10-04 16:40 UTC
From: brent dot halsey at huntington dot com Assigned:
Status: Closed Package: ibm_db2 (PECL)
PHP Version: 5.1.4 OS: SuSe Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: brent dot halsey at huntington dot com
New email:
PHP Version: OS:

 

 [2006-10-02 15:49 UTC] brent dot halsey at huntington dot com
Description:
------------
This is identical to Bug #6483
When I run configure with IBM_DB2 I get an error at my make step.  However- my pdo_odbc extension is working just fine and allows me to connect to my DB2 database.  

Reproduce code:
---------------
'./configure' '--with-mysql=/srv/mysql/mysql-standard-5.0.24a-linux-i686-glibc23' '--with-apxs2=/srv/apache-2058/apache/bin/apxs' '--with-ibm-db2=/opt/IBM/db2/V8.1' '--with-pdo-odbc=ibm-db2,/home/db2inst1/sqllib' 

etmdweb1:/srv/db2Patch/adcl # db2level
DB21085I  Instance "db2inst1" uses "32" bits and DB2 code release "SQL08020"
with level identifier "03010106".
Informational tokens are "DB2 v8.1.0.64", "s040812", "MI00086", and FixPak "7".
Product is installed at "/opt/IBM/db2/V8.1".


Expected result:
----------------
I expect it to make and make install successfully and allow me to call the DB2 CLI directly from my PHP source code.  

Actual result:
--------------
etmdweb1:/srv/php/php-5.1.4/ext/ibm_db2 # make
/bin/sh /srv/php/php-5.1.4/ext/ibm_db2/libtool --mode=compile gcc  -I. -I/srv/php/php-5.1.4/ext/ibm_db2 -DPHP_ATOM_INC -I/srv/php/php-5.1.4/ext/ibm_db2/include -I/srv/php/php-5.1.4/ext/ibm_db2/main -I/srv/php/php-5.1.4/ext/ibm_db2 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/opt/IBM/db2/V8.1/include  -DHAVE_CONFIG_H  -g -O2   -c /srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c -o ibm_db2.lo
mkdir .libs
 gcc -I. -I/srv/php/php-5.1.4/ext/ibm_db2 -DPHP_ATOM_INC -I/srv/php/php-5.1.4/ext/ibm_db2/include -I/srv/php/php-5.1.4/ext/ibm_db2/main -I/srv/php/php-5.1.4/ext/ibm_db2 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/opt/IBM/db2/V8.1/include -DHAVE_CONFIG_H -g -O2 -c /srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c  -fPIC -DPIC -o .libs/ibm_db2.o
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c: In function `_php_db2_connect_helper':
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:972: error: `SQL_ATTR_PING_DB' undeclared (first use in this function)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:972: error: (Each undeclared identifier is reported only once
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:972: error: for each function it appears in.)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c: In function `zif_db2_server_info':
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:3795: error: `SQL_DATABASE_CODEPAGE' undeclared (first use in this function)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c: In function `zif_db2_client_info':
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:4218: error: `SQL_APPLICATION_CODEPAGE' undeclared (first use in this function)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:4229: error: `SQL_CONNECT_CODEPAGE' undeclared (first use in this function)
make: *** [ibm_db2.lo] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-02 15:54 UTC] kfbombar at us dot ibm dot com
Can you please configure IBM_DB2 like the following:

--with-IBM_DB2=...

instead of:

--with-ibm_db2=

and let us know the results.  Thank you.
 [2006-10-02 16:04 UTC] brent dot halsey at huntington dot com
I ran it again with 
'./configure' '--with-mysql=/srv/mysql/mysql-standard-5.0.24a-linux-i686-glibc23' '--with-apxs2=/srv/apache-2058/apache/bin/apxs' '--with-IBM_DB2=/opt/IBM/db2/V8.1' '--with-pdo-odbc=ibm-db2,/home/db2inst1/sqllib'
and when I did my make command I got the same error:
etmdweb1:/srv/php/php-5.1.4 # make
/bin/sh /srv/php/php-5.1.4/libtool --silent --preserve-dup-deps --mode=compile gcc  -Iext/ibm_db2/ -I/srv/php/php-5.1.4/ext/ibm_db2/ -DPHP_ATOM_INC -I/srv/php/php-5.1.4/include -I/srv/php/php-5.1.4/main -I/srv/php/php-5.1.4 -I/usr/local/include/libxml2 -I/srv/php/php-5.1.4/ext/date/lib -I/opt/IBM/db2/V8.1/include -I/srv/mysql/mysql-standard-5.0.24a-linux-i686-glibc23/include -I/srv/php/php-5.1.4/TSRM -I/srv/php/php-5.1.4/Zend    -I/usr/include -g -O2  -prefer-non-pic -c /srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c -o ext/ibm_db2/ibm_db2.lo
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c: In function `_php_db2_connect_helper':
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:1342: error: `SQL_ATTR_PING_DB' undeclared (first use in this function)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:1342: error: (Each undeclared identifier is reported only once
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:1342: error: for each function it appears in.)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c: In function `zif_db2_server_info':
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:4424: error: `SQL_DATABASE_CODEPAGE' undeclared (first use in this function)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c: In function `zif_db2_client_info':
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:4863: error: `SQL_APPLICATION_CODEPAGE' undeclared (first use in this function)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:4876: error: `SQL_CONNECT_CODEPAGE' undeclared (first use in this function)
make: *** [ext/ibm_db2/ibm_db2.lo] Error 1
 [2006-10-03 06:39 UTC] helmut_tessarek at evermeet dot cx
Please source the db2profile before running configure and make.

. /home/db2inst1/sqllib/db2profile

Please tell us the outcome. Thanks.
 [2006-10-03 07:33 UTC] brent dot halsey at huntington dot com
I ran the following:

etmdweb1:/srv/php/php-5.1.4 # source /home/db2inst1/sqllib/db2profile

etmdweb1:/srv/php/php-5.1.4 # './configure' '--with-mysql=/srv/mysql/mysql-standard-5.0.24a-linux-i686-glibc23' '--with-apxs2=/srv/apache-2058/apache/bin/apxs' '--with-IBM_DB2=/opt/IBM/db2/V8.1' '--with-pdo-odbc=ibm-db2,/home/db2inst1/sqllib'

etmdweb1:/srv/php/php-5.1.4 # make

and got this again:

/bin/sh /srv/php/php-5.1.4/libtool --silent --preserve-dup-deps --mode=compile gcc  -Iext/ibm_db2/ -I/srv/php/php-5.1.4/ext/ibm_db2/ -DPHP_ATOM_INC -I/srv/php/php-5.1.4/include -I/srv/php/php-5.1.4/main -I/srv/php/php-5.1.4 -I/usr/local/include/libxml2 -I/srv/php/php-5.1.4/ext/date/lib -I/opt/IBM/db2/V8.1/include -I/srv/mysql/mysql-standard-5.0.24a-linux-i686-glibc23/include -I/srv/php/php-5.1.4/TSRM -I/srv/php/php-5.1.4/Zend    -I/usr/include -g -O2  -prefer-non-pic -c /srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c -o ext/ibm_db2/ibm_db2.lo
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c: In function `_php_db2_connect_helper':
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:1342: error: `SQL_ATTR_PING_DB' undeclared (first use in this function)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:1342: error: (Each undeclared identifier is reported only once
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:1342: error: for each function it appears in.)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c: In function `zif_db2_server_info':
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:4424: error: `SQL_DATABASE_CODEPAGE' undeclared (first use in this function)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c: In function `zif_db2_client_info':
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:4863: error: `SQL_APPLICATION_CODEPAGE' undeclared (first use in this function)
/srv/php/php-5.1.4/ext/ibm_db2/ibm_db2.c:4876: error: `SQL_CONNECT_CODEPAGE' undeclared (first use in this function)
make: *** [ext/ibm_db2/ibm_db2.lo] Error 1
 [2006-10-03 08:41 UTC] helmut_tessarek at evermeet dot cx
Ok, it seems that you have not installed the DB2 header files to compile the module. You have either just installed the Runtime or the Admin Client. You need to install the Application Developer Client to get the DB2 header files installed.
(You can try to find db2cli1.h on your machine. My guess is that you won't find it...)
 [2006-10-03 08:55 UTC] helmut_tessarek at evermeet dot cx
Sorry, I just reconsidered. Since you are able to compile the pdo IBMDB2 module, all the DB2 header files must have been installed. It is still very strange that you get this error message. What happens when you issue the following command (after doing a 'make distclean'):

etmdweb1:/srv/php/php-5.1.4 # './configure'
'--with-mysql=/srv/mysql/mysql-standard-5.0.24a-linux-i686-glibc23'
'--with-apxs2=/srv/apache-2058/apache/bin/apxs'
'--with-IBM_DB2=/home/db2inst1/sqllib'
'--with-pdo-odbc=ibm-db2,/home/db2inst1/sqllib'


etmdweb1:/srv/php/php-5.1.4 # make
 [2006-10-03 09:08 UTC] helmut_tessarek at evermeet dot cx
Another thing. Can you tell me the output of 

./configure --help |grep IBM
 [2006-10-03 09:09 UTC] brent dot halsey at huntington dot com
Yea- just a second- it is actually getting further than it did before, dare I say, it might actually work with that different path for IBM_DB2...  I'll keep you posted when it finishes the make step, perhaps even the make install!!! :-)
 [2006-10-03 09:14 UTC] brent dot halsey at huntington dot com
Ok- it did make it much further along in the make step this time, but died with what appears to be the same error.

I ran the command you mentioned and got this:
etmdweb1:/srv/php/php-5.1.4 # ./configure --help |grep IBM
  --with-IBM_DB2=DIR             Include IBM DB2 Univeral Database and Cloudscape support.
                                 headers and libraries, defaults to /opt/IBM/db2/V8.1
  --with-ibm-db2=DIR    Include IBM DB2 support.  DIR is the DB2 base

The other strange thing is that I couldn't find that file you mentioned, db2cli1.h or db2clil.h - either way, I couldn't seem to find it.

Do you think the --with-ibm-db2 command does anything here too?

Thanks for all of the support!
 [2006-10-03 09:34 UTC] helmut_tessarek at evermeet dot cx
The '--with-ibm-db2' command is for the unified ODBC driver component of PHP, which actually uses native DB2 cli calls.
(This odbc_db2 interface is much slower than the native driver and does not have all the nice features we have.)
The native DB2 driver will be compiled with the '--with-IBM_DB2' command.

Please run a 'db2licm -l' as the DB2 instance user. I need to know which edition of DB2 you have installed. How have you installed it? db2setup or db2_install? If you have used db2setup (GUI), have you checked the Application Development support?

You definitely need the include files to compile the module.
The include files must be loctated in
/opt/IBM/db2/V8.1/include
and
/home/db2inst1/sqllib/include
 [2006-10-03 09:43 UTC] brent dot halsey at huntington dot com
I installed DB2 from the cd, without the GUI, I'm pretty sure it was db2_install.  

When I try to run db2licm -l as db2inst1 or root it says command not found.

Would you like me to capture the inlcude directories and post them?
 [2006-10-03 09:48 UTC] helmut_tessarek at evermeet dot cx
Yes, please post the captured directories.

What CD have you used?

Runtime Client
Administration Client
Application Developer Client
DB2 Express-C
DB2 Express
DB2 Workgroup
DB2 Connect
DB2 Enterprise

If you have used the ./db2_install script, then all files of the DB2 edition on your CD have been installed.
I just need to know which product you have installed.
 [2006-10-03 09:56 UTC] brent dot halsey at huntington dot com
Here are the include directories:

etmdweb1:/ # dir /home/db2inst1/sqllib/include
lrwxrwxrwx  1 root dbadmin1 25 Oct  3 06:31 /home/db2inst1/sqllib/include -> /opt/IBM/db2/V8.1/include


etmdweb1:/ # dir /opt/IBM/db2/V8.1/include
\total 3209
drwxr-xr-x   5 bin  bin    2840 Sep 21 01:39 .
drwxr-xr-x  25 root root    608 Sep 13 16:22 ..
drwxr-xr-x   2 bin  bin     840 Sep 21 01:39 cobol_a
drwxr-xr-x   2 bin  bin     840 Sep 21 01:39 cobol_i
drwxr-xr-x   2 bin  bin     840 Sep 21 01:39 cobol_mf
-r--r--r--   1 bin  bin  208820 May 11  2003 db2ApiDf.f
-r--r--r--   1 bin  bin  219128 May 11  2003 db2ApiDf.h
-r--r--r--   1 bin  bin   10850 May 11  2003 db2AuCfg.h
-r--r--r--   1 bin  bin    6470 May 11  2003 db2gse.h
-r--r--r--   1 bin  bin    5683 May 11  2003 db2psmd.h
-r--r--r--   1 bin  bin     999 Aug 15  2004 dxx.h
-r--r--r--   1 bin  bin   14941 Aug 15  2004 dxxrc.h
-r--r--r--   1 bin  bin   93251 May 11  2003 sql.f
-r--r--r--   1 bin  bin  101177 May 11  2003 sql.h
-r--r--r--   1 bin  bin    2487 May 11  2003 sql1252a.f
-r--r--r--   1 bin  bin    2176 May 11  2003 sql1252a.h
-r--r--r--   1 bin  bin    2484 May 11  2003 sql1252b.f
-r--r--r--   1 bin  bin    2173 May 11  2003 sql1252b.h
-r--r--r--   1 bin  bin    8146 May 11  2003 sqladef.h
-r--r--r--   1 bin  bin   62992 May 11  2003 sqlaprep.f
-r--r--r--   1 bin  bin   84943 May 11  2003 sqlaprep.h
-r--r--r--   1 bin  bin    4019 May 11  2003 sqlca.h
-r--r--r--   1 bin  bin    1877 May 11  2003 sqlca_92.f
-r--r--r--   1 bin  bin    1846 May 11  2003 sqlca_cn.f
-r--r--r--   1 bin  bin    2082 May 11  2003 sqlca_cs.f
-r--r--r--   1 bin  bin   26694 May 11  2003 sqlcli.h
-r--r--r--   1 bin  bin   55371 May 11  2003 sqlcli1.h
-r--r--r--   1 bin  bin  114544 May 11  2003 sqlcodes.f
-r--r--r--   1 bin  bin  104821 May 11  2003 sqlcodes.h
-r--r--r--   1 bin  bin   12415 May 11  2003 sqlda.h
-r--r--r--   1 bin  bin    2007 May 11  2003 sqldact.f
-r--r--r--   1 bin  bin    2481 May 11  2003 sqle819a.f
-r--r--r--   1 bin  bin    2171 May 11  2003 sqle819a.h
-r--r--r--   1 bin  bin    2478 May 11  2003 sqle819b.f
-r--r--r--   1 bin  bin    2168 May 11  2003 sqle819b.h
-r--r--r--   1 bin  bin    2483 May 11  2003 sqle850a.f
-r--r--r--   1 bin  bin    2173 May 11  2003 sqle850a.h
-r--r--r--   1 bin  bin    2480 May 11  2003 sqle850b.f
-r--r--r--   1 bin  bin    2170 May 11  2003 sqle850b.h
-r--r--r--   1 bin  bin    2482 May 11  2003 sqle932a.f
-r--r--r--   1 bin  bin    2171 May 11  2003 sqle932a.h
-r--r--r--   1 bin  bin    2482 May 11  2003 sqle932b.f
-r--r--r--   1 bin  bin    2171 May 11  2003 sqle932b.h
-r--r--r--   1 bin  bin  120258 May 11  2003 sqlenv.f
-r--r--r--   1 bin  bin  129505 May 11  2003 sqlenv.h
-r--r--r--   1 bin  bin   95636 May 11  2003 sqlext.h
-r--r--r--   1 bin  bin    9201 May 11  2003 sqljacb.h
-r--r--r--   1 bin  bin     630 May 11  2003 sqlmed.h
-r--r--r--   1 bin  bin  300375 May 11  2003 sqlmon.f
-r--r--r--   1 bin  bin  289192 May 11  2003 sqlmon.h
-r-xr-xr-x   1 bin  bin  115974 May 11  2003 sqlqg_catalog.h
-r-xr-xr-x   1 bin  bin   12262 May 11  2003 sqlqg_connection.h
-r-xr-xr-x   1 bin  bin    2036 May 11  2003 sqlqg_fenced_generic_nickname.h
-r-xr-xr-x   1 bin  bin    2043 May 11  2003 sqlqg_fenced_generic_server.h
-r-xr-xr-x   1 bin  bin    1716 May 11  2003 sqlqg_fenced_generic_user.h
-r-xr-xr-x   1 bin  bin    1740 May 11  2003 sqlqg_fenced_generic_wrapper.h
-r-xr-xr-x   1 bin  bin    2245 May 11  2003 sqlqg_fenced_nickname.h
-r-xr-xr-x   1 bin  bin    3681 May 11  2003 sqlqg_fenced_server.h
-r-xr-xr-x   1 bin  bin    1293 May 11  2003 sqlqg_fenced_user.h
-r-xr-xr-x   1 bin  bin    1799 May 11  2003 sqlqg_fenced_wrapper.h
-r-xr-xr-x   1 bin  bin   36156 May 11  2003 sqlqg_misc.h
-r-xr-xr-x   1 bin  bin    3425 May 11  2003 sqlqg_nickname.h
-r-xr-xr-x   1 bin  bin   20234 May 11  2003 sqlqg_operation.h
-r-xr-xr-x   1 bin  bin   14302 May 11  2003 sqlqg_request.h
-r-xr-xr-x   1 bin  bin   12612 May 11  2003 sqlqg_runtime_data_operation.h
-r-xr-xr-x   1 bin  bin    5849 May 11  2003 sqlqg_server.h
-r-xr-xr-x   1 bin  bin    3703 May 11  2003 sqlqg_unfenced_generic_nickname.h
-r-xr-xr-x   1 bin  bin    2425 May 11  2003 sqlqg_unfenced_generic_server.h
-r-xr-xr-x   1 bin  bin    1703 May 11  2003 sqlqg_unfenced_generic_user.h
-r-xr-xr-x   1 bin  bin    1258 May 11  2003 sqlqg_unfenced_generic_wrapper.h
-r-xr-xr-x   1 bin  bin    1644 May 11  2003 sqlqg_unfenced_nickname.h
-r-xr-xr-x   1 bin  bin   10567 May 11  2003 sqlqg_unfenced_server.h
-r-xr-xr-x   1 bin  bin    2761 May 11  2003 sqlqg_unfenced_user.h
-r-xr-xr-x   1 bin  bin    4040 May 11  2003 sqlqg_unfenced_wrapper.h
-r-xr-xr-x   1 bin  bin    2592 May 11  2003 sqlqg_user.h
-r-xr-xr-x   1 bin  bin    3470 May 11  2003 sqlqg_utils.h
-r-xr-xr-x   1 bin  bin    5820 May 11  2003 sqlqg_wrapper.h
-r--r--r--   1 bin  bin  100018 May 11  2003 sqlstate.f
-r--r--r--   1 bin  bin   48553 May 11  2003 sqlstate.h
-r--r--r--   1 bin  bin    3392 May 11  2003 sqlsystm.h
-r--r--r--   1 bin  bin    1326 May 11  2003 sqludf.f
-r--r--r--   1 bin  bin   31823 May 11  2003 sqludf.h
-r--r--r--   1 bin  bin  229169 May 11  2003 sqlutil.f
-r--r--r--   1 bin  bin  275927 May 11  2003 sqlutil.h
-r--r--r--   1 bin  bin   12520 May 11  2003 sqluv.h
-r--r--r--   1 bin  bin   11896 May 11  2003 sqluvend.h
-r--r--r--   1 bin  bin   20287 May 11  2003 sqlxa.h


As for the cd, I am pretty sure it was DB2 Enterprise- I will need to get with the DBA to grab the disc again and verify what procedures we followed- I know that when we installed the DB2 connect client at first, we did not have the header files and I was getting an error when trying to compile php with db2.  Then I was going to install everything on the CD thinking that all header files would be available, but I saw an option to install what I thought was the Application Developer Client, it may not have been though... I'll check on that.  However, when I recompiled php after that install, I was able to get it to work with the pdo-odbc extension, just not the direct cli extension, which it turns out, I need for three part names...   I'll let you know as soon as I can get the cd.  Thanks!
 [2006-10-03 10:07 UTC] helmut_tessarek at evermeet dot cx
I'm not quite sure what really happened, but for some reason your DB2 environment does not seem to be ok.
When using the db2_install script, everything on the CD is installed. On the Enterprise CD, you can choose, if you want to install the server, the client or the development client.
If you have installed the server, then everything is included. As I've seen, all the include files are there, so you have definitely installed a DB2 product, which is usable for compiling the module.

You have written that 'db2licm -l' is not found, so the DB2 environment is not set up correctly. When installing DB2 via the script, you will have to create the instances manually.
 [2006-10-03 10:10 UTC] brent dot halsey at huntington dot com
Ok- the dba just gave me a different disc this time- DB2 Connect Personal Edition 8.2.  I'm going to try and install everything from this disc, hoping it fixes whatever issues I'm having.  Let me know if you have any other thoughts.
Thanks
 [2006-10-03 10:24 UTC] helmut_tessarek at evermeet dot cx
DB2 Connect Personal Edition is for client connection to a DB2 on a mainfraime only. You are not even able to create local databases with this edition of DB2.
Don't use this edition.
 [2006-10-03 10:27 UTC] brent dot halsey at huntington dot com
Our db2 databases all reside on a mainframe- we simply need a client to connect to them- is that still an issue?
My linux configuration does not have a gui, so I have to run db2_install.

I have three choices: 
etmdweb1:/media/cdrom # ./db2_install


Specify one or more of the following keywords,
separated by spaces, to install DB2 products.

 Keyword        Product Description
 DB2.CONPE      DB2 Connect Personal Edition for LINUX
 DB2.ADMCL      DB2 Administration Client for LINUX
 DB2.ADCL       DB2 Application Development Client for LINUX

Enter "help" to redisplay product names.

Enter "quit" to exit.


Should I install just the Application Development Client?
 [2006-10-03 11:55 UTC] brent dot halsey at huntington dot com
I reinstalled everything from the personal edition cd.  It still does not work.  I finally found the db2licm command located in /opt/IBM/db2/V8.1/adm.  When I run it with -l it comes back with no response.  Does this mean that the db2 products are not installed properly?  If so, why does the pdo-odbc driver work with DB2?
 [2006-10-04 15:19 UTC] brent dot halsey at huntington dot com
Figured it out-

I uninstalled DB2 Connect from the Linux box and reinstalled it, this did nothing.  The version of db2 connect was 8.1 with fix patch 7, which according to what I had read, was suitable for this extension.  However, I downloaded the fixpatch 13 from the IBM website and after installing it, php compiled fine.  I installed just the developemnt client fix patch at first, which didn't help, but when I installed the full fix patch, it seems to have solved the issue.  I can now call the db2 databases using three part names!  Thanks for all of the help.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Oct 21 13:01:27 2019 UTC