php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57271 Class 'Runkit_Sandbox' not found
Submitted: 2006-10-01 15:32 UTC Modified: 2006-10-04 06:53 UTC
From: info at wiredtek dot info Assigned:
Status: Not a bug Package: runkit (PECL)
PHP Version: 5.1.6 OS: Gentoo/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: info at wiredtek dot info
New email:
PHP Version: OS:

 

 [2006-10-01 15:32 UTC] info at wiredtek dot info
Description:
------------
pecl-runkit compile fine, but Sandbox Support is always 
disabled:

phpinfo() report:

runkit support - enabled
version - 0.9
Custom Superglobal support - enabled
Sandbox Support - disable or unavailable
Runtime Manipulation - enabled

configure process report:

checking whether to enable runkit support... yes, shared
checking wheter to enable runtime manipulation of 
functions/classes/constants... yes, shared
checking whether to enable registration of user-defined 
autoglobals... yes, shared
checking whether to enable Sandbox support... yes, shared


what is the reasone that make Sandbox Support disabled?

here below there are some extra infos about my enviroment:

System uname: 2.6.18-gentoo i686 VIA Samuel 2
Gentoo Base System version 1.12.5
Last Sync: Sun, 01 Oct 2006 14:30:08 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 
1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=c3 -O2 -pipe -fno-ident -fomit-frame-pointer -momit-leaf-frame-pointer -fforce-addr -fweb -ftracer"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="-march=c3 -O2 -pipe -fno-ident -fomit-frame-pointer -momit-leaf-frame-pointer -fforce-addr -fweb -ftracer"
MAKEOPTS="-j1 -s"


Reproduce code:
---------------
$sanbox_options = array(
   'safe_mode'=>true,
   'allow_url_fopen'=>'false',
   'disable_functions'=>'exec,shell_exec,passthru,system',
   'runkit.superglobal' => '_CORE',
   'disable_classes'=>'myAppClass');
$sandbox = new Runkit_Sandbox($sanbox_options);

Expected result:
----------------
$sandbox must be a Runkit_Sandbox object

Actual result:
--------------
Fatal error: Class 'Runkit_Sandbox' not found

but pecl is correctly loaded:
- "php -m" report it.
- phpinfo() report the runkit section (see before).
- extension_loaded('runkit') return always TRUE.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-02 10:44 UTC] pollita@php.net
Sandboxing support requires that PHP (not just the extension mind you, but the main PHP bundle) be compiled with ZTS support enabled.

The configure switch would be --enable-maintainer-zts, not sure what gentoo calls this within it's USE flags.
 [2006-10-04 06:53 UTC] info at wiredtek dot info
thank you for the help; was i my mistake, i don't have 
read well the README, sorry.

now i can fix the Gentoo ebuild and prevent these type of 
situations.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jun 16 06:01:30 2019 UTC