php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57234 SDOName written out instead of original element name
Submitted: 2006-09-14 05:46 UTC Modified: 2007-06-25 08:49 UTC
From: simonslaws at googlemail dot com Assigned:
Status: No Feedback Package: SCA_SDO (PECL)
PHP Version: 5.1.4 OS: XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
13 + 5 = ?
Subscribe to this entry?

 
 [2006-09-14 05:46 UTC] simonslaws at googlemail dot com
Description:
------------
XML elements can have and sdo name attribute to tell SDO how it should refer to the element. However SDO is writing this SDO name out as the element name when the data objects are written to XML. The resulting XML does not validate. 

Reproduce code:
---------------
Schema
                
  <element name="RootElement34">
    <complexType>
      <sequence>
        <element name="ElementWithSDOName" sdo:name="ElementWithSDONameSDOName" type="string"/>
      </sequence>
    </complexType>
  </element>

Input XML

<tns:RootElement34 xmlns:tns="http://www.apache.org/tuscany/interop"
	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
	xsi:schemaLocation="http://www.apache.org/tuscany/interop interop34.xsd">
	<ElementWithSDOName>ElementWithSDOName</ElementWithSDOName>
</tns:RootElement34>


Expected result:
----------------
<tns:RootElement34 xmlns:tns="http://www.apache.org/tuscany/interop"
	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
	xsi:schemaLocation="http://www.apache.org/tuscany/interop interop34.xsd">
	<ElementWithSDOName>ElementWithSDOName</ElementWithSDOName>
</tns:RootElement34>

Actual result:
--------------
<RootElement34 xmlns="http://www.apache.org/tuscany/interop" xsi:type="RootElement34" xmlns:tns="http://www.apache.org/tuscany/interop" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <ElementWithSDONameSDOName>ElementWithSDOName</ElementWithSDONameSDOName>
</RootElement34>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-09-14 08:07 UTC] simonslaws at googlemail dot com
This also applies to the attributes with SDO name
 [2007-04-24 18:11 UTC] cem@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PECL.


I think you're probably describing a Tuscany problem, but there's no link in the defect and I don't see an obvious issue which corresponds. Please either add a link, or if this is a problem with the PHP extension, confirm that it still exists with the latest release.
 [2007-06-25 08:49 UTC] cem@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Jul 19 10:01:26 2019 UTC