php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57173 Exceptions thrown across .so boundry fail
Submitted: 2006-08-07 12:59 UTC Modified: 2006-11-27 06:33 UTC
From: simon_laws at uk dot ibm dot com Assigned:
Status: Wont fix Package: SCA_SDO (PECL)
PHP Version: 5.1.4 OS: Linux (Fedora Core 5)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
49 + 14 = ?
Subscribe to this entry?

 
 [2006-08-07 12:59 UTC] simon_laws at uk dot ibm dot com
Description:
------------
In some linux builds the test/sdo\tests\XMLDAS\PHPUnitTests\XMLDASTest.php fails on the test testFileExceptionThrownAndWarningIssuedWhenXsdFileIsNotPresent.
The symptom is described below. 

Reproduce code:
---------------
See testFileExceptionThrownAndWarningIssuedWhenXsdFileIsNotPresent in test/sdo\tests\XMLDAS\PHPUnitTests\XMLDASTest.php  

Expected result:
----------------
SDOFileNotFoundException

Actual result:
--------------
SDORuntimeException

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-07 13:12 UTC] simon_laws at uk dot ibm dot com
The cause of this problem is a little hard to detect. XSD files are loaded when the XML DAS is created (SDO_XML_DAS::create) and the catch blocks here are the culprit. The SDOFileNotFound exception is thrown by the SAX2Parser code but by the time it arrives here it is a SDORuntimeException. We can avoid the problem in this case by adding some extra testing to the SDORuntimeException catch block to test the classname of the exception (the SDORuntimeException base class holds a string representation of the actual classname) and acting accordingly. It will work but its not a complete fix.
 [2006-11-27 06:33 UTC] cem@php.net
The XML DAS is no longer a separate library, so it is not possible to reproduce this.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Aug 13 15:05:45 2022 UTC