php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57159 won't build against 5.2
Submitted: 2006-07-27 04:43 UTC Modified: 2006-11-26 10:30 UTC
From: soporte at onfocus dot cl Assigned:
Status: Closed Package: runkit (PECL)
PHP Version: 5_2 CVS-2006-07-27 OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: soporte at onfocus dot cl
New email:
PHP Version: OS:

 

 [2006-07-27 04:43 UTC] soporte at onfocus dot cl
Description:
------------
Hi: runkit does not currently build against php 5.2RC1

Reproduce code:
---------------
rebuild it without sandboxing. 

Expected result:
----------------
compile as always..

Actual result:
--------------
/usr/src/packages/BUILD/runkit-0.9/runkit_import.c: In function 'php_runkit_import_class_props':
/usr/src/packages/BUILD/runkit-0.9/runkit_import.c:230: warning: passing argument 2 of 'zend_unmangle_property_name' makes integer from pointer without a cast
/usr/src/packages/BUILD/runkit-0.9/runkit_import.c:230: error: too few arguments to function 'zend_unmangle_property_name'
make: *** [runkit_import.lo] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.88475 (%build)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-09 09:39 UTC] taneli at crasman dot fi
The following patch makes Runkit compile, but I'm not so sure of its correctness:

--- runkit-0.9-orig/runkit_import.c     2006-06-07 00:06:08.000000000 +0300
+++ runkit-0.9/runkit_import.c  2006-11-09 15:30:47.000000000 +0200
@@ -227,7 +227,7 @@
                        char *cname = NULL, *pname = key;

 #ifdef ZEND_ENGINE_2
-                       zend_unmangle_property_name(key, &cname, &pname);
+                       zend_unmangle_property_name(key, key_len, &cname, &pname);
 #endif
                        if (zend_hash_exists(&dce->default_properties, key, key_len)) {
                                if (override) {
 [2006-11-26 09:09 UTC] bawitdaba at gmail dot com
Runkit does not compile on 5.2.0 final, you have to manually patch runkit_import.c and change:

zend_unmangle_property_name(key, &cname, &pname);
to
zend_unmangle_property_name(key, key_len, &cname, &pname);

after this runkit worked perfect for me on php 5.2.0
 [2006-11-26 10:30 UTC] soporte at onfocus dot cl
the CVS version compiles just fine anyway...
 [2007-08-09 12:51 UTC] info at adaniels dot nl
Is runkit package still maintained? Because there hasn't been an update in over a year and will not compile with any new PHP version because of this bug.

Get it from CVS, is no longer a valid argument in my opinion.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jun 25 07:01:23 2021 UTC