php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #57152 more robust handling of protocol issues
Submitted: 2006-07-24 19:10 UTC Modified: 2006-07-25 02:45 UTC
From: serhat at sakarya dot nl Assigned:
Status: Wont fix Package: memcache (PECL)
PHP Version: Irrelevant OS: RHEL / CentOS 4..3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
32 - 6 = ?
Subscribe to this entry?

 
 [2006-07-24 19:10 UTC] serhat at sakarya dot nl
Description:
------------
In some cases, recent memcached (1.1.13-pre2) versions contain a protocol violation: a GET will not always result in a response ending with "END". This has happened to me for large data test sets (300k) on the same node. The result is that PHP memcache marks the server as down even though it's still up. When I telnet into the server, I can get all the data, except that "END" is missing.

This is not a bug with PHP memcache, but it would help to make it more tolerant for this memcached bug; the required data (number of bytes) is already there anyway.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-25 02:45 UTC] tony2001 at phpclub dot net
I don't think we're going to workaround any memcached bugs - as you've said, it's a protocol violation and should be fixed there.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed May 22 11:01:33 2024 UTC