|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #57148 Unintuitive option name: "cookiesession"
Submitted: 2006-07-20 20:12 UTC Modified: 2007-02-15 09:38 UTC
From: malbe at adinet dot com dot uy Assigned: mike (profile)
Status: Wont fix Package: pecl_http (PECL)
PHP Version: 5.1.2 OS: Linux 2.4
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: malbe at adinet dot com dot uy
New email:
PHP Version: OS:


 [2006-07-20 20:12 UTC] malbe at adinet dot com dot uy
pecl_http 1.1.0 
Just a suggestion: change the name of "cookiesession" option to somthing like "nosessioncookies" or "nocookiessession".
I think it describes the behavior better. In example: when you read "cookiesession" => true, you could assume that the programmer meant "it's true I want to use the session cookies"
Thanks for your great package, and best regards!



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-12 10:49 UTC]
It follows the CURLOPT naming.
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 29 14:03:34 2022 UTC