php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57130 Wrong method name
Submitted: 2006-07-08 16:51 UTC Modified: 2006-10-12 02:51 UTC
From: wieri420 at gmail dot com Assigned:
Status: Not a bug Package: POP3 (PECL)
PHP Version: 5.1.4 OS: Debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wieri420 at gmail dot com
New email:
PHP Version: OS:

 

 [2006-07-08 16:51 UTC] wieri420 at gmail dot com
Description:
------------
According to get_extension_funcs("pop3") and http://wiki.cc/php/POP3 there is a method called:
delete_message()

However, the methods name really is :
delete()


It's confusing. See reproduce code.

Additional info:
Using php 5.1.4 with POP3 1.0.2

./configure --enable-modules --enable-mods-shared --enable-so --with-freetype-dir=/usr/include/freetype2 --with-gd --with-ttf --with-mysql --with-regex=php --enable-ftp --with-gettext --enable-sockets --with-zlib --with-kerberos --with-exec-dir=/usr/lib/php5/libexec --with-dom=shared,/usr --with-zlib-dir=/usr --with-jpeg-dir=shared,/usr --with-xpm-dir=shared,/usr/X11R6 --with-png-dir=shared,/usr --with-xsl --with-gettext --with-apxs2=/usr/bin/apxs2

I added extension=pop3.so to php.ini.

Reproduce code:
---------------
$pop = new pop3( "pop.server.com:110","user", "pass");
print_r(get_class_methods($pop));
print_r(get_extension_funcs("pop3")); 

Expected result:
----------------
Array
(
    [0] => pop3
    [1] => get_message_count
    [2] => get_account_size
    [3] => get_message_ids
    [4] => get_message_sizes
    [5] => get_message_header
    [6] => get_message_size
    [7] => get_message
    [8] => delete_message
    [9] => undelete
)
Array
(
    [0] => pop3_open
    [1] => pop3_close
    [2] => pop3_get_message_count
    [3] => pop3_get_account_size
    [4] => pop3_get_message_ids
    [5] => pop3_get_message_sizes
    [6] => pop3_get_message_header
    [7] => pop3_get_message_size
    [8] => pop3_get_message
    [9] => pop3_delete_message
    [10] => pop3_undelete
)

Actual result:
--------------
Array
(
    [0] => pop3
    [1] => get_message_count
    [2] => get_account_size
    [3] => get_message_ids
    [4] => get_message_sizes
    [5] => get_message_header
    [6] => get_message_size
    [7] => get_message
    [8] => delete
    [9] => undelete
)
Array
(
    [0] => pop3_open
    [1] => pop3_close
    [2] => pop3_get_message_count
    [3] => pop3_get_account_size
    [4] => pop3_get_message_ids
    [5] => pop3_get_message_sizes
    [6] => pop3_get_message_header
    [7] => pop3_get_message_size
    [8] => pop3_get_message
    [9] => pop3_delete_message
    [10] => pop3_undelete
)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-08 16:54 UTC] wieri420 at gmail dot com
-
 [2006-10-11 20:21 UTC] ilia at prohost dot org
Thank you for taking the time to write to us, but this is not
a bug.

This is the intended name for the function.
 [2006-10-12 02:51 UTC] wieri420 at gmail dot com
Ok, then the documentation available on http://wiki.cc/php/POP3 is wrong.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 26 09:01:24 2020 UTC