php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57128 go-pear.php fails on PHP < v4.3.0
Submitted: 2006-07-07 16:26 UTC Modified: 2006-07-08 07:40 UTC
From: me at gavitron dot com Assigned: pajoye (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: Irrelevant OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: me at gavitron dot com
New email:
PHP Version: OS:

 

 [2006-07-07 16:26 UTC] me at gavitron dot com
Description:
------------
I tried to install PEAR under php v 4.2.1, but the command in the documentation: 

# lynx -source http://go-pear.org/ | php

Fails with the following:

PHP Fatal error:  Call to undefined function:  set_include_path() in - on line 594


Test script:
---------------
Sure enough, 
http://www.php.net/set_include_path

tells me that this wonderful system call is >= 4.3.0 only!

I made the a simple change to a local copy of go-pear.php and it chugged along merrily.

This following 4-line diff should fix it for everyone:

594c594
< set_include_path($ptmp);
---
> ini_set('include_path', $ptmp);


Regards,
Gavin.


Expected result:
----------------
Should install on PHP v4.2.0+

Actual result:
--------------
only installs on PHP v4.3.0+

go-pear.php dies with:

PHP Fatal error:  Call to undefined function:  set_include_path() in - on line 594

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-08 07:34 UTC] wiesemann@php.net
Not a documentation issue, it's a website problem.
 [2006-07-08 07:37 UTC] pajoye@php.net
Yes, we have to keep 4.2.x support. But you should really update your system, to do not say you must update it.
 [2006-07-08 07:40 UTC] pajoye@php.net
This bug has been fixed in CVS.

If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET).

If this was a problem with the pear.php.net website, the change should be live shortly.

Otherwise, the fix will appear in the package's next release.

Thank you for the report and for helping us make PEAR better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 11:05:52 2022 UTC