php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57124 Cannot print in LANDSCAPE using php_printer.dll
Submitted: 2006-07-04 02:18 UTC Modified: 2006-07-04 07:50 UTC
From: mangan at aptrut dot com Assigned:
Status: Not a bug Package: PECL bug system (PECL)
PHP Version: 5.1.2 OS: Win XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mangan at aptrut dot com
New email:
PHP Version: OS:

 

 [2006-07-04 02:18 UTC] mangan at aptrut dot com
Description:
------------
When trying to set PRINTER_OPTION for printing LANDSCAPE the actuall setting doesn't seem to be affected.

I'm using the precompiled PHP version 5.1.2 on Windows XP.

Reproduce code:
---------------
printer_set_option($handle, PRINTER_ORIENTATION, PRINTER_ORIENTATION_LANDSCAPE);


Expected result:
----------------
I expected the page to be printed in LANDSCAPE

Actual result:
--------------
The page prints in PORTRAIT

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-04 07:34 UTC] mangan at aptrut dot com
As suggested by tanes73 at hotmail dot com in bug thread 18412 http://bugs.php.net/bug.php?id=18412 it seems like the set options is not set correctly. But after looking at the source code for print.c I think I found the code mentioned by tanes73 at line 583-590 but under the case VALID_OPTIONS. 

The problem now is how to call the printer_set_option with the option VALID_OPTIONS?

Because the passed option parameter is parsed in the extension you can't just call it with option = 16 (value for VALID_OPTIONS).
I can't find the call ever being made in the source code internally, so there doesn't seem to be any automatic calling being done.
 [2006-07-04 07:42 UTC] pierre dot php at gmail dot com
Can you please keep using bugs.php.net? Printer has no release in pecl and it is not a bug system issue :)
 [2006-07-04 07:50 UTC] mangan at aptrut dot com
Ok, sorry about that!

Just followed the Bugs link from http://pecl4win.php.net. I will move my report to bugs.php.net at once. 

Cheers
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 14:03:35 2021 UTC