php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57101 oci8 1.2.1 uses zend_strtod, which php 4.3.x doesn't have
Submitted: 2006-06-21 16:01 UTC Modified: 2006-06-22 16:28 UTC
From: Tim dot Mooney at ndsu dot edu Assigned:
Status: Closed Package: oci8 (PECL)
PHP Version: 4.3.2 OS: Red Hat Linux 3 AS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
14 - 10 = ?
Subscribe to this entry?

 
 [2006-06-21 16:01 UTC] Tim dot Mooney at ndsu dot edu
Description:
------------
I'm not sure if this is truly a bug, or just a "gotcha", but oci8-1.2.1 uses zend_strtod, which Red Hat's php 4.3.2 doesn't have.  That results in undefined symbol errors from the loader when oci8.so is loaded.

Maybe your intent is that oci8-1.2.1 requires php >= X.Y.Z, which is fine.  It's just not documented that there's a minimum version of php that oci8 1.2.1 will work with, so I was surprised when 1.2.1 built just fine with php 4.3.x, but wouldn't load.

Reproduce code:
---------------
Take Red Hat 3 AS's Source RPM for php-4.3.2-20.  Modify the spec so that Red Hat's patched ext/oci8 is removed, and oci8-1.2.1 is installed in its place.  Modify the "build" line so that it uses the --with-oci8=instantclient,shared,$ORACLE_HOME instead of what Red Hat is using.

Rebuild using --define 'oracle 1'. The build will succeed but the resulting oci8.so can't be used because it depends on a Zend symbol that php 4.3.2 doesn't have.

Expected result:
----------------
A warning or error at configure time, e.g.

  oci8-1.2.1 requires PHP X.Y.Z or greater

or a note in the README.

Actual result:
--------------
As explained above.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-06-22 16:28 UTC] tony2001 at phpclub dot net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 08:01:31 2024 UTC