php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57038 Cannot install with pear
Submitted: 2006-05-25 07:17 UTC Modified: 2006-05-25 11:31 UTC
From: eamonnk at shopecentre dot ie Assigned:
Status: Not a bug Package: zip (PECL)
PHP Version: 4.4.1 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: eamonnk at shopecentre dot ie
New email:
PHP Version: OS:

 

 [2006-05-25 07:17 UTC] eamonnk at shopecentre dot ie
Description:
------------
Zip 1.0

C:\PHP\PEAR>pear install zip
downloading zip-1.0.tgz ...
Starting to download zip-1.0.tgz (4,930 bytes)
.....done: 4,930 bytes
3 source files, building
The DSP zip.dsp does not exist.

Standard windows install of php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-25 07:24 UTC] pierre dot php at gmail dot com
It does not work on windows. You have to use the dlls available at pecl4win.php.net.
 [2006-05-25 11:05 UTC] eamonnk at shopecentre dot ie
I've followed the instructions on php.net
I've downloaded the php_zip.dll
I've edited php.ini
I've reset apache
I've reset my computer
I've double checked php.ini
I've reset apache and my computer again, but it's still resulting in
Fatal error: Call to undefined function: zip_open() in C:\Program Files\Apache Group\Apache2\htdocs\test.php on line 2
 [2006-05-25 11:31 UTC] pierre dot php at gmail dot com
Which dll have you downloaded? The exact link you used on pecl4win.php.net.

You do not need to restart the computer but apache.

Which php.ini is used by php? check it in phpinfo(); Be sure to use the same.

Also, please use the mailing list (pecl-dev or php-install) to ask further support questions. There is no bug here.
 [2007-02-09 18:32 UTC] jeanloup at gmail dot com
I've been trying to install it as well and got the same error message. 

I tried pecl bundle zip which downloaded the sources on my win2k machine, it turns out that zip.dsp is indeed not there.

So anyone has suggestions on how to install this package under windows? I have the dll zip installed as well so that shouldn't be the source of the problem...
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Jan 21 08:01:23 2020 UTC