php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57020 Unable to compile Fileinfo-1.0.3
Submitted: 2006-05-17 16:43 UTC Modified: 2006-05-17 17:00 UTC
From: mark dot wiggins at uconn dot edu Assigned:
Status: Not a bug Package: Fileinfo (PECL)
PHP Version: 4.3.4 OS: s390x-suse-linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mark dot wiggins at uconn dot edu
New email:
PHP Version: OS:

 

 [2006-05-17 16:43 UTC] mark dot wiggins at uconn dot edu
Description:
------------
I've tried installing Fileinfo-1.0.3 by "pecl install Fileinfo", to
which I get "Allowed memory size of 8388608 bytes exhausted" and by
"download, phpize, ./configure, and make install" to which I get

"/usr/lib64/gcc-lib/s390x-suse-linux/3.3.3/../../../../s390x-suse-linux/bin/ld:
warning: s390:31-bit architecture of input file
`/usr/lib/libmagic.a(apptype.o)' is incompatible with s390:64-bit
output 

/usr/lib64/gcc-lib/s390x-suse-linux/3.3.3/../../../../s390x-suse-linux/bin/ld:
BFD 2.15.90.0.1.1 20040303 (SuSE Linux) internal error, aborting at
../../bfd/reloc.c line 4274 in
bfd_generic_get_relocated_section_contents

/usr/lib64/gcc-lib/s390x-suse-linux/3.3.3/../../../../s390x-suse-linux/bin/ld:
Please report this bug." 

during the "make install". I've tried everything that I can to no
avail. I've googled all of the errors and searched your bug site and I
can't find anything. The only reason that I'm reporting this is because
of the last line in the above error "Please report this bug". 

Sincerely
Mark Wiggins
University of Connecticut
860-486-2792



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-17 17:00 UTC] mike@php.net
"ld: Please report this bug." means you should report this bug to your software vendor. This is not a bug of PHP or Fileinfo but your build tools.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 14:03:37 2021 UTC