php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56978 Inconsistent PHP delimiters
Submitted: 2006-04-25 06:54 UTC Modified: 2006-10-30 06:32 UTC
From: simonslaws at googlemail dot com Assigned: cem (profile)
Status: Closed Package: SCA_SDO (PECL)
PHP Version: 5.1.2 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: simonslaws at googlemail dot com
New email:
PHP Version: OS:

 

 [2006-04-25 06:54 UTC] simonslaws at googlemail dot com
Description:
------------
The PHP/SDO extension generally uses the PHP delimiter <?php. However two files:

 SDO/DAS/Relational/UpdateNonContainmentReferenceAction.php
 SDO/DAS/Relational/PDOConstants.colon.inc.php

use the <? delimiter. This can catch out the unwary who haven't configured PHP to take account of this.

Reproduce code:
---------------
Ensure that all php files in PHP SDO used the same <?php delimiter.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-18 15:20 UTC] mfp@php.net
Although this bug was raised when 1.0.1 was current, and a 1.0.2 has been released, this bug has not been fixed. This is curious since the changes have been made in our internal CVS repository. It looks as if not all the changes got moved across.

We have had another user run into this bug in the meantime.
 [2006-07-20 09:48 UTC] mfp@php.net
The fact that PDO_constants does not begin correctly can cause more subtle problems where the constants do not get set and hence the renormaliseResultSet logic does not work correctly.
 [2006-07-26 09:45 UTC] cem@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Nov 27 02:03:14 2021 UTC