php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56942 ingres_connect does not work with $options
Submitted: 2006-04-07 09:13 UTC Modified: 2017-01-29 04:22 UTC
From: jurvillier at inrets dot fr Assigned: grantc (profile)
Status: No Feedback Package: ingres (PECL)
PHP Version: 5.1.1 OS: SunOS 5.10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jurvillier at inrets dot fr
New email:
PHP Version: OS:

 

 [2006-04-07 09:13 UTC] jurvillier at inrets dot fr
Description:
------------
Using : 
INGRES_EXT_VERSION : 1.2.1 INGRES_API_VERSION : 4
version.rel on client (web server) : II 3.0.2 (su9.us5/109)
version.rel on ingres server  machine : II 2.5/0011 (su4.us5/00) 8908
php : PHP Version 5.1.2 (and not 5.1.1 as I could not give 5.1.2 in the php_version field of this form)

Description :
ingres_connect() doesn't work with 4 parameters :
when giving 3 parameters ($base, $user, pass) it works fine;
if, with the 3 same parameters, I add a 4th one, $options, an array which is previously given, I get an error.



Reproduce code:
---------------
$options = array("date_format" => INGRES_DATE_MULTINATIONAL4 );
ingres_connect($base, $user, pass, $options);
I get the following error :
Warning: ingres_connect() [function.ingres-connect]: Ingres error : 6399 : User authorization check failed. Your user identifier was not known to this installation. Contact your system manager for further assistance. in /usr/.../table.php on line 22
Warning: ingres_connect() [function.ingres-connect]: Ingres SQLSTATE : 5000H in /usr/..../table.php on line 22 

Expected result:
----------------
no error


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-19 08:13 UTC] grantc@php.net
Hi,

does this reproduce with a server running Ingres 3.0.x?

grant
 [2006-04-19 09:06 UTC] jurvillier at inrets dot fr
Hi
I Can't say if it reproduces with a 3.0 server, and no time to check it in the next days, sorry
 [2017-01-20 20:51 UTC] heiglandreas@php.net
-Status: Assigned +Status: Feedback
 [2017-01-20 20:51 UTC] heiglandreas@php.net
Is this still relevant?
 [2017-01-29 04:22 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jul 17 22:01:26 2019 UTC