php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56934 PDOStatement::bindParam() crashes with GPF
Submitted: 2006-04-03 09:43 UTC Modified: 2006-04-09 01:40 UTC
From: bastian at pixelfashion dot net Assigned: wez (profile)
Status: Closed Package: PDO_OCI (PECL)
PHP Version: 5_1 CVS-2006-04-03 OS: Debian Linux 3.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bastian at pixelfashion dot net
New email:
PHP Version: OS:

 

 [2006-04-03 09:43 UTC] bastian at pixelfashion dot net
Description:
------------
Hi,

some correction first: i uses PHP 5.1.2, but i can't find this under the above PHP version list.


Reproduce code:
---------------
PHP-Code:

$db = new PDO("oci:dbname=dev", 'devuser', 'devpasswd');
$db->setAttribute (PDO::ATTR_ERRMODE, PDO::ERRMODE_WARNING);
$qry = "BEGIN test.pkg_test.test(?); END;";
$stmt = $db->prepare($qry);
$hw = "Hello World";
$stmt->bindParam('1', $hw, PDO::PARAM_STR|PDO::PARAM_INPUT_OUTPUT, 255);
$stmt->execute();
print_r($stmt->errorInfo());

Oracle-Stored-Procedure (Schema: test, Package: pkg_test):

PROCEDURE TEST(
p_varchar2 IN OUT varchar2
)
AS
BEGIN
p_varchar2 := 'Joman';
END;


Expected result:
----------------
Got a blank screen (= GPF).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-03 10:02 UTC] bastian at pixelfashion dot net
Same error with PHP 5.1.1 (hardening-patch-5.1.1-0.4.8)
 [2006-04-04 02:51 UTC] bastian at pixelfashion dot net
make terminates with the following error msg:

/usr/src/php-5.1.3RC2/ext/standard/info.c: In function `php_print_gpcse_array':
/usr/src/php-5.1.3RC2/ext/standard/info.c:155: error: too many arguments to function `zend_print_zval_ex'
make: *** [ext/standard/info.lo] Error 1

php configure settings:

./configure \
--with-config-file-path=/etc/php5 \
--with-apxs2=/usr/bin/apxs2 \
--with-oci8=/opt/oracle/10.1.0 \
--with-openssl \
--with-mcrypt \
--with-bz2=/usr/bin/bzip2 \
--with-ldap \
--with-ldap-sasl \
--enable-ftp \
--with-flatfile \
--with-zlib \
--with-bz2 \
--with-gd \
--with-jpeg-dir=/usr/lib \
--with-png-dir=/usr/lib \
--with-freetype-dir=/usr/lib \
--with-tidy \
--enable-gd-native-ttf \
--with-xml \
--enable-inline-optimization \
--enable-memory-limit \
--enable-magic-quotes \
--disable-debug \
--enable-calendar \
--enable-sockets \
--enable-trans-sid \
--enable-sigchild \
--enable-soap \
--with-pdo-oci
 [2006-04-06 04:37 UTC] bastian at pixelfashion dot net
Seems to be running with http://snaps.php.net/php5.1-200604060830.tar.gz. Testing ...
 [2006-04-09 01:40 UTC] wez@php.net
Presumed resolved.  Please set this report to Open if that is not the case.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Sep 15 16:01:27 2019 UTC