php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56932 Failure to build
Submitted: 2006-04-02 05:36 UTC Modified: 2006-10-11 20:24 UTC
From: costin dot raiu at gmail dot com Assigned:
Status: Closed Package: POP3 (PECL)
PHP Version: 5.1.1 OS: Fedora Core 5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: costin dot raiu at gmail dot com
New email:
PHP Version: OS:

 

 [2006-04-02 05:36 UTC] costin dot raiu at gmail dot com
Description:
------------
Pop3 doesn't build with newer (PHP 5+?) versions. Changes in the zend_object structure prevent it from compiling correctly.



Reproduce code:
---------------
/pop3/pop3-1.0.2/pop3.c: In function 'pop3_objects_new':
/pop3/pop3-1.0.2/pop3.c:175: error: 'zend_object' has no member named 'in_get'
/pop3/pop3-1.0.2/pop3.c:176: error: 'zend_object' has no member named 'in_set'

Expected result:
----------------
Expected it to build.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-02 06:02 UTC] costin dot raiu at gmail dot com
Quick fix - in 

pop3.c: PHP_POP3_API zend_object_value pop3_objects_new(zend_class_entry *class_type TSRMLS_DC)

replace:

intern->zo.in_get = 0;
intern->zo.in_set = 0;

with:

intern->zo.guards = NULL;
 [2006-10-11 20:24 UTC] ilia at prohost dot org
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 [2012-05-17 01:51 UTC] php-bugs-2012 at ryandesign dot com
It's been over six years since this bug was reported. Will a new version of the software containing this fix ever be released to PECL?

http://pecl.php.net/package/pop3
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 00:01:34 2019 UTC