php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #56846 Add package version field to bug editing form
Submitted: 2006-02-18 06:51 UTC Modified: 2006-02-19 17:57 UTC
From: techtonik@php.net Assigned: pajoye (profile)
Status: Not a bug Package: PECL bug system (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: techtonik@php.net
New email:
PHP Version: OS:

 

 [2006-02-18 06:51 UTC] techtonik@php.net
Description:
------------
In canned response there is a notice:

'...If you are able to reproduce the bug with one of the latest versions, please change the package version on this bug report to the version you tested and change the status back to
"Open".
Again, thank you for your continued support of PEAR.
'

The problem is that smb. forgot to include field to "change the package version" in bug reporting/editing form.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-18 06:56 UTC] techtonik@php.net
Sorry. I overlooked the fact that this field is actually present in bug reporting page. But it still missing from bug editing page.  http://pear.php.net/bugs/bug.php?id=4983&edit=1
 [2006-02-18 07:02 UTC] pajoye@php.net
Sorry but you are confusing :)

The package version field is present in each form:
- initial bug submit page, a select field
- Developer, a text field
- Edit submission, a text field

Can you please check again and name the page using the "button" names, it may help to actually know which page you are talking about :)
 [2006-02-18 08:50 UTC] techtonik@php.net
Oops. =) Too little time and too many thing to do. Well, yes, the field is already present. It is nice to see that. But is it possible to make it select box in edit/developer forms also? Is it possible to list all available for download revisions of a package?

For example, when you're trying to enter a new bug report there is only latest version available http://pear.php.net/bugs/report.php?package=File_Find
 [2006-02-19 13:17 UTC] pajoye@php.net
Thank you for taking the time to write to us, but this is not
a bug.

No, if an user is not using the last version, he first has to update, pretty obvious no?
 [2006-02-19 16:36 UTC] techtonik@php.net
If there is only one stable version, when it is obvious, but if there are stable, beta and alpha versions - it is not.
 [2006-02-19 17:57 UTC] pajoye@php.net
Good point and already solved, it does check for the latest and the latest stable if any.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 12:01:30 2024 UTC