php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56837 compile error
Submitted: 2006-02-12 02:03 UTC Modified: 2006-02-14 15:43 UTC
From: m dot islam at accesstel dot net Assigned:
Status: Not a bug Package: Fileinfo (PECL)
PHP Version: 4.3.11 OS: Redhat Enterprise Linux ES-3
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: m dot islam at accesstel dot net
New email:
PHP Version: OS:

 

 [2006-02-12 02:03 UTC] m dot islam at accesstel dot net
Description:
------------
when i am trying to pear install fileinfo i am getting the following error

/tmp/tmpYfJoAS/Fileinfo-1.0.3/fileinfo.c: In function `zm_startup_finfo':
/tmp/tmpYfJoAS/Fileinfo-1.0.3/fileinfo.c:196: `MAGIC_PRESERVE_ATIME' undeclared (first use in this function)
/tmp/tmpYfJoAS/Fileinfo-1.0.3/fileinfo.c:196: (Each undeclared identifier is reported only once
/tmp/tmpYfJoAS/Fileinfo-1.0.3/fileinfo.c:196: for each function it appears in.)
/tmp/tmpYfJoAS/Fileinfo-1.0.3/fileinfo.c:197: `MAGIC_RAW' undeclared (first use in this function)
/tmp/tmpYfJoAS/Fileinfo-1.0.3/fileinfo.c: In function `zif_finfo_set_flags':
/tmp/tmpYfJoAS/Fileinfo-1.0.3/fileinfo.c:328: void value not ignored as it ought to be
/tmp/tmpYfJoAS/Fileinfo-1.0.3/fileinfo.c: In function `_php_finfo_get_type':
/tmp/tmpYfJoAS/Fileinfo-1.0.3/fileinfo.c:358: void value not ignored as it ought to be
/tmp/tmpYfJoAS/Fileinfo-1.0.3/fileinfo.c:402: void value not ignored as it ought to be
make: *** [fileinfo.lo] Error 1
`make' failed



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-14 15:43 UTC] mike@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PECL.

Dup of bug #6284
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jun 13 21:01:33 2024 UTC