php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56791 PDO::Mysql and Persistence
Submitted: 2006-01-21 19:23 UTC Modified: 2006-04-09 01:31 UTC
From: abcde at abcde dot com Assigned:
Status: Not a bug Package: PDO (PECL)
PHP Version: 5.1.1 OS: Linux UML 2.6.14
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: abcde at abcde dot com
New email:
PHP Version: OS:

 

 [2006-01-21 19:23 UTC] abcde at abcde dot com
Description:
------------
I am using PDO to connect to a MySQL database with ATTR_PERSISTENT set to true. If PDO accesses the database, the database is restarted, and then PDO attempts to access the database again, the errorInfo indicates that the database has "gone away." I assume that PDO is caching that the database link has failed and is not trying to reestablish the connection, which seems like incorrect behavior. When ATTR_PERSISTENT is set to false, the problem disappears.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-09 01:31 UTC] wez@php.net
Not enough info and bogus email address supplied.
Thanks for nothing; we have no way to tell if this is a real issue or a duplicate of another problem.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 22:01:23 2020 UTC