php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56761 Tiger test segfaults
Submitted: 2006-01-02 07:00 UTC Modified: 2006-02-27 06:39 UTC
From: nlopess@php.net Assigned: mike (profile)
Status: Closed Package: hash (PECL)
PHP Version: 5_1 CVS-2006-01-02 OS: Solaris
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nlopess@php.net
New email:
PHP Version: OS:

 

 [2006-01-02 07:00 UTC] nlopess@php.net
Description:
------------
The tiger test segfaults.

Actual result:
--------------
http://mega.ist.utl.pt/~ncpl/hash_tiger_dump.txt

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-02 08:42 UTC] mike@php.net
I can't reproduce.

Is that a 64bit Solaris box?
Where's the segfault actually happening?

I suspect that the detection for a 32bit integer type could be wrong for Solaris.
 [2006-01-02 12:51 UTC] nlopess@php.net
its this server: http://www.sun.com/servers/entry/280r/specs.html
it has a UltraSPARC III processor (64 bits).

I don't have time to help you in fixing the problem now...
 [2006-01-07 18:09 UTC] nlopess@php.net
OK, I've instaled gcc 3.3.6 and with the patch you gave me in IRC I still get a segfault: http://mega.ist.utl.pt/~ncpl/php_hash_dump2.txt

Nuno
 [2006-01-08 04:59 UTC] mike@php.net
And I guess without the patch too?
 [2006-01-08 06:46 UTC] nlopess@php.net
yep, it crashs without the patch, too.
BTW, the .cvsignore file is missing in the tests directory.
 [2006-01-14 15:28 UTC] nlopess@php.net
I've tested today in two different powerpc machines (g4 and g5) and although they don't crash, they return bad results.

Take a look at the tests report:
http://mega.ist.utl.pt/~ncpl/php_test_results_20060114_1202.txt 64 bits
http://mega.ist.utl.pt/~ncpl/php_test_results_20060114_1214-32.txt 32 bits
 [2006-02-19 18:44 UTC] mike@php.net
Nuno, could you please test again, I've commited a patch.

Thank you!
 [2006-02-21 14:20 UTC] nlopess@php.net
Ah thanks for the patch!
I've tested on a PowerPc g4 and it passed the test :) This week I'll try to test on a SPARC/solaris and on a g5/mac machines.
 [2006-02-21 16:00 UTC] mike@php.net
Thanks! 

I actually wrote the patch on a G5 ;)
 [2006-02-27 06:35 UTC] mike@php.net
I already got a positive response from Tony, he tested on a Sun Blade-100.

Nuno, can you verify?
 [2006-02-27 06:39 UTC] nlopess@php.net
Ah, Sorry I totally forgot to update this report.
I already tested on a Solaris 7 box and it worked. I hadn't tested on a G5 yet, but as you already did, I'm closing.

Thanks,
Nuno
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jul 10 23:01:24 2020 UTC