php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56753 Segfault with Prado applications
Submitted: 2005-12-28 14:40 UTC Modified: 2009-02-16 20:13 UTC
From: rodolfo dot gonzalez at gmail dot com Assigned:
Status: No Feedback Package: APC (PECL)
PHP Version: 5.1.1 OS: Slackware 10.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: rodolfo dot gonzalez at gmail dot com
New email:
PHP Version: OS:

 

 [2005-12-28 14:40 UTC] rodolfo dot gonzalez at gmail dot com
Description:
------------
Apache 1.3.33, PHP 5.1.1, APC 3.0.8, Prado 2.1RC1 (www.xisc.com). I compiled APC with:

CFLAGS="-O2 -march=athlon -mcpu=athlon" ./configure --enable-apc --enable-apc-mmap --with-apxs
--with-php-config=/usr/local/bin/php-config

I try to run a Prado application. The first page works fine. The next page I load (with post or get) causes:

[Wed Dec 28 13:36:52 2005] [notice] child pid 842 exit signal Segmentation fault (11)

Reproduce code:
---------------
The code can be found in the Prado examples contained in the package.

Actual result:
--------------
[Wed Dec 28 13:36:52 2005] [notice] child pid 842 exit signal Segmentation fault (11)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-24 01:56 UTC] rasmus@php.net
Is this still happening with current CVS?
 [2006-02-24 17:50 UTC] rodolfo dot gonzalez at gmail dot com
Yes, it still happens. In my test server PHP is 5.1.2 and APC config looks this way:

apc
APC Support 	enabled
Version 	3.0.9-dev
MMAP Support 	Enabled
MMAP File Mask 	no value
Revision 	$Revision: 3.79 $
Build Date 	Feb 24 2006 14:01:06

Directive	Local Value	Master Value
apc.cache_by_default	On	On
apc.enable_cli	Off	Off
apc.enabled	On	On
apc.file_update_protection	2	2
apc.filters	no value	no value
apc.gc_ttl	3600	3600
apc.max_file_size	1M	1M
apc.mmap_file_mask	no value	no value
apc.num_files_hint	2000	2000
apc.optimization	On	On
apc.shm_segments	1	1
apc.shm_size	32	32
apc.slam_defense	On	On
apc.ttl	0	0
apc.user_entries_hint	100	100
apc.user_ttl	0	0

Prado version is the HEAD of 2.x

Tnx.
 [2006-02-25 04:18 UTC] rasmus@php.net
How about a backtrace then?
 [2009-02-16 20:13 UTC] shire@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Mar 29 22:01:26 2020 UTC