php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56726 implement preparer fallback when talking with 4.0 servers
Submitted: 2005-12-16 08:10 UTC Modified: 2006-04-09 04:11 UTC
From: pav at FreeBSD dot org Assigned: wez (profile)
Status: Closed Package: PDO_MYSQL (PECL)
PHP Version: 5.1.1 OS: FreeBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pav at FreeBSD dot org
New email:
PHP Version: OS:

 

 [2005-12-16 08:10 UTC] pav at FreeBSD dot org
Description:
------------
PDO_MYSQL compiled with mysql-client 5.0 can't talk with 4.0.X servers, because 4.0.X servers don't understand prepare commands. Implement a fallback to "emulated" preparer when talking to 4.0.X and older servers, per TODO comment in source.



Reproduce code:
---------------
Patch against pecl release 1.0.1

http://people.freebsd.org/~pav/PDO_MYSQL-mysql_driver.c.patch

Expected result:
----------------
get PDOStatement object with results

Actual result:
--------------
getting error message "Unknown command"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-04-09 04:11 UTC] wez@php.net
Thanks for the patch!
Fixed in CVS.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Sep 23 14:01:24 2020 UTC