php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56592 rar does not support unicode filenames
Submitted: 2005-10-11 15:35 UTC Modified: 2009-11-19 12:33 UTC
From: steve_php at nanovox dot com Assigned:
Status: Closed Package: rar (PECL)
PHP Version: 5.0.3 OS: fedora core 2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: steve_php at nanovox dot com
New email:
PHP Version: OS:

 

 [2005-10-11 15:35 UTC] steve_php at nanovox dot com
Description:
------------
I have some files with korean filenames that I've compressed into a rar file using winrar on my windows XP system, and now I want to be able to access them in a php script on a linux system.  The filenames appear as something like Ÿ???佺/???α???01.txt so they're not practical in an extracted form.  I'd like to be able to extract one of the files at a time to a specified filename like temp.txt, and then access them with my script.  The problem is, the rar functions sabatage the filenames to be something more like A,3aAa10/3 0I+auO01.txt, so I can't do matches on the filenames because I'm searching for the korean unicode when rar_list returns a list of filenames that are completely wrong.

Reproduce code:
---------------
place a folder/file like Ÿ???佺/???α???01.txt into a rar file using windows.  run the rar_open and rar_list functions on the rar file and observe how different the filenames become.

Expected result:
----------------
I would expect a rar object that return "Ÿ???佺/???α???01.txt" when you call getName() on that same rar object.

Actual result:
--------------
getName() returns a value such as "A,3aAa10/3 0I+auO01.txt" instead of the proper unicode.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-11 15:49 UTC] tony2001 at phpclub dot net
Are you able to work with such files using unrar?
(http://rarlabs.com/rar_add.htm)
 [2006-02-27 07:35 UTC] mike@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2009-11-19 12:33 UTC] glopes at nebm dot ist dot utl dot pt
Fixed in revision #291015.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 19 07:01:23 2020 UTC