php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56570 /usr/bin/phpize: line 105: aclocal: command not found
Submitted: 2005-09-30 18:17 UTC Modified: 2006-02-24 03:22 UTC
From: cristic at interaktonline dot com Assigned:
Status: Not a bug Package: APC (PECL)
PHP Version: 5.0.3 OS: Fedora Core 4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
31 + 42 = ?
Subscribe to this entry?

 
 [2005-09-30 18:17 UTC] cristic at interaktonline dot com
Description:
------------
When the automake and autoconf miss from the machine the phpize output will display:

Configuring for:
PHP Api Version:         20031224
Zend Module Api No:      20041030
Zend Extension Api No:   220040412
/usr/bin/phpize: line 105: aclocal: command not found

instead of making an initial check of these tools installed on machine and to throw the appropriate error message.

Fixed after installing the automake.

Reproduce code:
---------------
[root@linux APC-3.0.8]# phpize

Expected result:
----------------
Configuring for:
PHP Api Version:         20031224
Zend Module Api No:      20041030
Zend Extension Api No:   220040412
Automake missing => minimal version required x.x.x

Actual result:
--------------
/usr/bin/phpize: line 105: aclocal: command not found

which is kind of cryptic

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-24 06:45 UTC] mk at kaiser-software dot de
This error happens also on freebsd >=5 because there are more than one version of automake and autoconf. Just to know that freebsd install all the binarys with a version extension.
aclocal as aclocal14 or aclocal15. To fix this just symlink to your preferred version.

we should also check for aclocal[0-9]+, autoconf[0-9]+, autoheader[0-9]+, automake[0-9]+...
 [2006-02-24 02:03 UTC] rasmus@php.net
I am going to bogus this for APC.  It really has nothing to do with APC.  If you feel strongly about not wanting to create that symlink, file a bug over at bugs.php.net.
 [2006-02-24 03:09 UTC] cristic at interaktonline dot com
I'm quite unclear to whom this bug belong. Do I have to move it to the phpize (bugs.php.net) as a request to be more friendly and less cryptical?

The original bug report has nothing to do with not creating a symbolic link to the correct version of automake but it is about a very cryptical error message that don't tell anything clear of what exactly is missing from the machine or what is found and what is expected.
 [2006-02-24 03:22 UTC] rasmus@php.net
Yes, but you filed the bug against APC.  phpize is not part of APC.  Go read through http://bugs.php.net/search.php?cmd=display&search_for=phpize
and if you don't find a bug that already covers this, file a new one.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 15:01:26 2019 UTC