php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56560 when loading pdo.so - undefined symbol: zend_declare_class_constant_long
Submitted: 2005-09-25 05:20 UTC Modified: 2005-09-30 22:48 UTC
From: akorthaus at web dot de Assigned: wez (profile)
Status: Closed Package: PDO (PECL)
PHP Version: 5.0.5 / 5.1.0RC1 OS: Linux 2.4.31 (gentoo)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
34 - 25 = ?
Subscribe to this entry?

 
 [2005-09-25 05:20 UTC] akorthaus at web dot de
Description:
------------
I build latest PECL PDO from CVS (to test latest config.m4 fixes...), it compiles fine, but I can't load pdo.so.

I tested with PHP 5.0.5 and PHP 5.1RC1:

$ php-5.1.0RC1 -m
php-5.1.0RC1: error while loading shared libraries: /home/akorthaus/bin/php-5.1.0RC1/lib/php/extensions/no-debug-non-zts-20050617/pdo.so: undefined symbol: zend_declare_class_constant_long

$ php-5.0.5 -m
php-5.0.5: error while loading shared libraries: /home/akorthaus/bin/php-5.0.5/lib/php/extensions/no-debug-non-zts-20041030/pdo.so: undefined symbol: zend_declare_class_constant_long

I used the correct phpize and php-config for building pdo.so.

Perhaps it has something to do with the latest changes from constants to class constants.

I compiled PHP with the following ./configure parameters: --prefix=/home/akorthaus/bin/php-5... --disable-all


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-25 06:56 UTC] akorthaus at web dot de
It works with the latest PHP-snapshot (php5-200509250830).
 [2005-09-30 22:48 UTC] wez@php.net
Fixed in CVS.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Dec 09 23:01:24 2019 UTC