php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56558 Interactive Downloads Graph Image URL error
Submitted: 2005-09-20 22:22 UTC Modified: 2006-10-18 15:29 UTC
From: abdrums at yahoo dot com Assigned: cellog (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: Irrelevant OS: Windows XP Pro SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: abdrums at yahoo dot com
New email:
PHP Version: OS:

 

 [2005-09-20 22:22 UTC] abdrums at yahoo dot com
Description:
------------
While looking at http://pecl.php.net/package-stats.php?cid=7&pid=335 and trying to modify the graph, I get at broken image.  Looking at the image URL though, I see the problem - an ampersand is being passed as an HTML entity and not as an ampersand.



Reproduce code:
---------------
Go here: http://pecl.php.net/package-stats.php?cid=7&pid=335

Try and change the graph!

Expected result:
----------------
I would expect to see an image from this URL:
http://pecl.php.net/package-stats-graph.php?pid=335&releases=1405_339900)

Actual result:
--------------
This is what I get though (no image, because of the following URL):
http://pecl.php.net/package-stats-graph.php?pid=335&releases=1405_339900


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-18 15:29 UTC] cellog@php.net
This bug has been fixed in CVS.

If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET).

If this was a problem with the pear.php.net website, the change should be live shortly.

Otherwise, the fix will appear in the package's next release.

Thank you for the report and for helping us make PEAR better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jan 17 04:01:23 2021 UTC