php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #56557 Add asynchronous multithreading to Runkit_Sandbox
Submitted: 2005-09-19 12:37 UTC Modified: 2021-05-10 15:06 UTC
Votes:3
Avg. Score:3.7 ± 0.9
Reproduced:0 of 0 (0.0%)
From: ibrash at gmail dot com Assigned: cmb (profile)
Status: Closed Package: runkit (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ibrash at gmail dot com
New email:
PHP Version: OS:

 

 [2005-09-19 12:37 UTC] ibrash at gmail dot com
Description:
------------
A useful feature might be asynchronous threading of calls to a Runkit_Sandbox so a long-running function call doesn't block the parent script.  It'd also be nice to expose the return value after it's done in a later call to the sandbox, but that'd probably make things much more difficult.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-05-10 15:06 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2021-05-10 15:06 UTC] cmb@php.net
I'm closing this ticket, since the proper place to report runkit
related issues is <https://github.com/zenovich/runkit/issues>.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jun 21 07:01:23 2021 UTC