php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56542 sqlite3.h not found by make
Submitted: 2005-09-13 20:42 UTC Modified: 2005-09-25 05:22 UTC
From: akorthaus at web dot de Assigned:
Status: Closed Package: PDO_SQLITE (PECL)
PHP Version: 5.0.3 OS: Linux 2.4.31 (gentoo)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: akorthaus at web dot de
New email:
PHP Version: OS:

 

 [2005-09-13 20:42 UTC] akorthaus at web dot de
Description:
------------
The same issue has been reported as http://pecl.php.net/bugs/bug.php?id=5000, I don't know why it has been marked bogus, but I'm quite sure it's a bug in config.m4 from PDO_SQLITE.

The problem only occours with PHP 5.0.4 and lastest 5.0-dev, not with PHP 5.1.

If I try to install PDO_SQLITE-1.0RC1 on PHP-5.0.4, I get errors during make, that sqlite3.h could not be found. Only if I copy it from sqlite/src/ (bundled with PECL PDO_SQLITE package) to "." the error disappears. But after that more files are missing: parse.h and sqliteInt.h. I also copy them to ".", solves the problem, but again other files missing...

Only if I do

cp sqlite/src/*.h .

the pdo_sqlite.so is created. The patch to config.m4 I posted in the other bug was a dirty hack, which worked for PDO_SQLITE-0.9, but fails for 1.0RC1, because more header files are missing.

Reproduce code:
---------------
install PHP 5.0.4
pear install PDO-beta
pear install PDO_SQLITE-beta

Expected result:
----------------
should install PDO and PDO_SQLITE

Actual result:
--------------
does not create/install PDO_SQLITE, make fails with errors caused by missing sqlite header files

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-24 22:33 UTC] wez@php.net
Fixed in CVS; the next PECL release should work for you.
 [2005-09-25 05:22 UTC] akorthaus at web dot de
Thanks Wez, the fix works for me. Tested with PHP 5.0.5 and 5.1.0 RC1. 

Sadly there is a new issue with loading latest PECL pdo.so now: http://pecl.php.net/bugs/bug.php?id=5514
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Oct 23 21:01:33 2019 UTC