|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56522 Fails to find zlib library
Submitted: 2005-09-02 11:34 UTC Modified: 2006-01-29 08:13 UTC
From: cyberlot at cyberlot dot net Assigned:
Status: Closed Package: memcache (PECL)
PHP Version: 5.0.3 OS: Fedora Core 4
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: cyberlot at cyberlot dot net
New email:
PHP Version: OS:


 [2005-09-02 11:34 UTC] cyberlot at cyberlot dot net
Can't use pear to install memcache anymore

memcache support requires ZLIB. Use --with-zlib-dir=<DIR>
`/tmp/tmprVj7sq/memcache-1.5/configure' failed

PHP compiles fine with zlib support and did not have to specify directory just --with-zlib

If I download memcache manually and do a 

./configure --with-zlib-dir=/usr/include

It compiles fine but it should look in /usr/include by default?

Reproduce code:
pear install memcache

Expected result:
A successfull install

Actual result:
 pear install memcache
downloading memcache-1.5.tgz ...
Starting to download memcache-1.5.tgz (14,291 bytes)
.....done: 14,291 bytes
4 source files, building
running: phpize
Configuring for:
PHP Api Version:         20031224
Zend Module Api No:      20041030
Zend Extension Api No:   220040412 warning: underquoted definition of PHP_WITH_PHP_CONFIG
  run info '(automake)Extending aclocal'
  or see warning: underquoted definition of PHP_EXT_BUILDDIR warning: underquoted definition of PHP_EXT_DIR warning: underquoted definition of PHP_EXT_SRCDIR warning: underquoted definition of PHP_ALWAYS_SHARED
acinclude.m4:19: warning: underquoted definition of PHP_PROG_RE2C
acinclude.m4:1915: warning: underquoted definition of PHP_TEST_BUILD
building in /var/tmp/pear-build-root/memcache-1.5
running: /tmp/tmprVj7sq/memcache-1.5/configure
checking build system type... i686-redhat-linux-gnu
checking host system type... i686-redhat-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM
checking for PHP extension directory... /usr/local/lib/php/extensions/no-debug-non-zts-20041030
checking for re2c... exit 0;
checking for gawk... gawk
checking whether to enable memcache support... yes, shared
checking for the location of libz... no
checking for the location of zlib... configure: error: memcache support requires ZLIB. Use --with-zlib-dir=<DIR>
`/tmp/tmprVj7sq/memcache-1.5/configure' failed


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-02 11:53 UTC] cyberlot at cyberlot dot net
I can replicate the bug on another machine.

memcache 1.4 is installed fine, can not install memcache 1.5 same error php 5.0.3

Tried to upgrade a 5.1.0RC1 from memcache 1.4 same problem, can't seem to find zlib. PEAR upgraded in both cases.

I found a box with pear 1.3.5 instead of 1.3.6 same problem

pear install memcache-1.4 WORKS!!!! its only when trying to upgrade to the latest memcache-1.5
 [2005-09-10 10:51 UTC] email at steffenweber dot net
I?m having the same problem with PHP 4.4.0 and PEAR 1.3.6.

Using "PHP_ZLIB_DIR=/usr/lib pear upgrade memcache" the installation seems to work fine first, but at the end I get the following output and the extension does not work:

Build process completed successfully
Installing '/var/tmp/pear-build-root/install-memcache-1.5//usr/lib/php/extensions/no-debug-non-zts-20020429/'
upgrade ok: memcache 1.5
Segmentation fault
 [2005-12-23 12:42 UTC] mikael at synd dot info
This issue should be fixed in the latest release 2.0.0, please verify that the issue does not persist by running

pear install pecl/memcache
 [2006-01-29 08:13 UTC] pear dot neufeind at speedpartner dot de
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at

Had same problem installing 1.5. The "trick" with setting PHP_ZLIB_DIR however worked excellent for me. Install with 2.0 even worked without any tricks. Marking it fixed in 2.0.
 [2007-07-12 11:22 UTC] jreck at reck dot dk
When I try to install memcache_2.1.2 with pear I get the following error:

# pear install -f memcache
downloading memcache-2.1.2.tgz ...
Starting to download memcache-2.1.2.tgz (22,285 bytes)
........done: 22,285 bytes
No handlers for package.xml version 2.0
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 14 23:01:30 2024 UTC