php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56511 Registering Multiple Superglobals Stops Apache
Submitted: 2005-08-25 16:20 UTC Modified: 2005-09-22 18:26 UTC
From: tfreeman at teamxl dot org Assigned:
Status: Not a bug Package: runkit (PECL)
PHP Version: 5_1 CVS-2005-08-25 (dev) OS: Win XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tfreeman at teamxl dot org
New email:
PHP Version: OS:

 

 [2005-08-25 16:20 UTC] tfreeman at teamxl dot org
Description:
------------
PECL Runkit V 0.4 as reported by RUNKIT_VERSION
Runkit DLL from PHP.net download site zip file for PECL 5.1
PHP from PHP.net download site zip file for PHP 5.1

php.ini
...
[runkit]
runkit.superglobal=_SYSDB,_USER

Apache starts without errors...
  PHP error reporting is set to E_ALL with
   DISPLAY_STARTUP_ERRORS on 
   LOG_ERRORS on and to a file

Running any PHP code (phpinfo() for example) results in Apache shutdown and restart.  No errors are logged anywhere, Apache or PHP logs.

If php.ini changed to register a single superglobal
php.ini
...
[runkit]
runkit.superglobal=_SYSDB

All works fine



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-22 18:26 UTC] pollita@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PECL.

Duplicate of #4676

Just fixed in CVS.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Mar 05 04:01:23 2021 UTC