php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56487 unable to compile xdiff
Submitted: 2005-08-11 05:32 UTC Modified: 2005-12-10 22:03 UTC
From: brian at matzon dot dk Assigned: mg (profile)
Status: Closed Package: xdiff (PECL)
PHP Version: 5.0.3 OS: Fedora Core 4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: brian at matzon dot dk
New email:
PHP Version: OS:

 

 [2005-08-11 05:32 UTC] brian at matzon dot dk
Description:
------------
 gcc -I. -I/tmp/tmpi8TmJJ/xdiff-1.3 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/xdiff-1.3/include -I/var/tmp/pear-build-root/xdiff-1.3/main -I/tmp/tmpi8TmJJ/xdiff-1.3 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/local/include -DHAVE_CONFIG_H -g -O2 -c /tmp/tmpi8TmJJ/xdiff-1.3/xdiff.c  -fPIC -DPIC -o .libs/xdiff.o
/tmp/tmpi8TmJJ/xdiff-1.3/xdiff.c:39: error: static declaration of 'fourth_arg_force_ref' follows non-static declaration
/usr/include/php/Zend/zend_modules.h:38: error: previous declaration of 'fourth_arg_force_ref' was here
make: *** [xdiff.lo] Error 1
`make' failed
[root@epia ~]# php --version
PHP 5.0.4 (cli) (built: Jul  4 2005 10:39:59)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.4-dev, Copyright (c) 1998-2004 Zend Technologies
[root@epia ~]# uname -a
Linux 2.6.12-1.1390_FC4 #1 Tue Jul 5 19:58:32 EDT 2005 i686 i686 i386 GNU/Linux


Reproduce code:
---------------
just did a pear -v install xdiff


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-23 11:07 UTC] mike@php.net
Probably caused by the fix for bug #3120
 [2005-10-26 04:51 UTC] mg at iceni dot pl
Code causing the error has been added here: http://cvs.php.net/diff.php/pecl/xdiff/xdiff.c?r1=1.10&r2=1.11&ty=u

Could you try:
a) download xdiff by hand
b) unpack it and enter xdiff directory
c) search & replace all occurences of 'fourth_arg_force_ref' into 'xdiff_func_arg' in file xdiff.c?
d) use command: phpize && ./configure && make

and check if it compiles? Due to my work, I'm unable to do it until next week.
 [2005-10-26 05:15 UTC] brian at matzon dot dk
replacing occurences made it all compile
 [2005-12-10 22:03 UTC] mg at iceni dot pl
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/xdiff


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 13:03:33 2021 UTC