php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #56486 time_t "bug" with SDO
Submitted: 2005-08-10 14:43 UTC Modified: 2006-10-30 06:23 UTC
From: arnar at 8 dot is Assigned: cem (profile)
Status: Closed Package: SCA_SDO (PECL)
PHP Version: 5_1 CVS-2005-08-10 (dev) OS: FreeBSD, Mac OSX
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: arnar at 8 dot is
New email:
PHP Version: OS:

 

 [2005-08-10 14:43 UTC] arnar at 8 dot is
Description:
------------
In SDO_List.cpp your typecasting a time_t as a long to the append function in DataObjectList, witch takes in long int. The problem is that time_t is not defined as long on all platforms, and long int DOES not have to be 32bit int like time_t is. long int can be 64bit.

DataObjectList should have a insert and append function that takes in time_t to allow better portability to platforms other then Linux and windows.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-11 05:47 UTC] cem@php.net
Sure, that was just a workaround. The real fix is coming.
 [2005-08-11 16:21 UTC] cem@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jun 17 18:01:27 2019 UTC