php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56463 Compiles but PHP cannot load it
Submitted: 2005-07-24 11:30 UTC Modified: 2005-08-01 05:09 UTC
From: listrecv at gmail dot com Assigned:
Status: Not a bug Package: vld (PECL)
PHP Version: 4.3.9 OS: Linux (CentOS release 4.1)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: listrecv at gmail dot com
New email:
PHP Version: OS:

 

 [2005-07-24 11:30 UTC] listrecv at gmail dot com
Description:
------------
vld-0.8.0
Install & compile - cannot be loaded as Zend Extension

Reproduce code:
---------------
$ php -z/usr/lib/php4/vld.so -n -m


Expected result:
----------------
should load

Actual result:
--------------
/usr/lib/php4/vld.so doesn't appear to be a valid Zend extension

(Note: same problem if try to run script:
$ php -z/usr/lib/php4/vld.so -n /tmp/test.php                                                                          
/usr/lib/php4/vld.so doesn't appear to be a valid Zend extension
Content-type: text/html
X-Powered-By: PHP/4.3.9
)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-01 05:09 UTC] php at derickrethans dot nl
Not a bug:

This warning is correct, it's a normal PHP extension which you need to load with -dextension=vld.so (afaik).
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 19 04:01:23 2020 UTC