php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56449 Download Requests Slow
Submitted: 2005-07-11 10:25 UTC Modified: 2005-07-11 10:51 UTC
From: gregory dot szorc at case dot edu Assigned:
Status: Not a bug Package: PECL website (PECL)
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gregory dot szorc at case dot edu
New email:
PHP Version: OS:

 

 [2005-07-11 10:25 UTC] gregory dot szorc at case dot edu
Description:
------------
Any HTTP request in http://pear.php.net/get/ take a long 
time (about 2 minutes) to process.  Any other page on the 
site works fine.

The client will send a HTTP GET request to a URL in http://
pear.php.net/get/.  Many seconds later the server will 
respond with the response and payload.  Some browsers time 
out because the requests takes so long.  The pear command 
doesn't even work because of the delay.

This problem only occurs from some addresses.  The problem 
also occurs with other sites running similar mirror 
resolution scripts (like www.php.net and www.mysql.com).  In 
my case, the problem exists for my entire university 
network.  The network engineers suspect it has something to 
do with our ISP, but we don't know what.  We are not sure if 
the problem is with the server-side script or somewhere on 
our end, including our ISP.

Reproduce code:
---------------
Only possible from some addresses.  I can provide a shell account to a machine where the problem exists.  Any address in 129.22.0.0/255.255.0.0 is affected.

Expected result:
----------------
Download requests are responsive.

Actual result:
--------------
Download requests are painfully slow.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-11 10:30 UTC] mj@php.net
Considering that only certain subnets are affected, this is most likely a firewall/routing/QoS issue on your side.
 [2005-07-11 10:32 UTC] mj@php.net
Just to make it clear:  Neither are we running any mirror redirection similar the systems used by MySQL or PHP nor are we employing a throttling infrastructure for the downloads.
 [2005-07-11 10:40 UTC] gregory dot szorc at case dot edu
Thank you for the prompt reply.

I am inclined to believe that there is some script voodoo/
transparent redirect happening at http://pear.php.net/get/ 
just because of the URL layout.  Is there any chance I could 
get a direct IP address or URL to download a file so I may 
go to our ISP with something concrete.  If the direct 
download went as normal, then I could definitely say that 
the problem is on my end.

If I am wrong about requests in /get/, just say so and we 
will consider this bug closed.
 [2005-07-11 10:47 UTC] mj@php.net
/get is a simple PHP script.  It only lacks the .php extension.  Unfortunately there is no other way to download files.

If you could tell me the IP address of your requests, I can query the access logs to see if anything magic goes on.
 [2005-07-11 10:51 UTC] gregory dot szorc at case dot edu
I have made requests from 129.22.115.102 today with multiple 
download agents.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jun 19 01:01:28 2019 UTC