php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56441 pdflib install_root problem
Submitted: 2005-07-07 08:26 UTC Modified: 2005-07-10 09:15 UTC
From: narender at classicinformatics dot com Assigned:
Status: Not a bug Package: PECL bug system (PECL)
PHP Version: 5.0.4 OS: Linux fedora
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: narender at classicinformatics dot com
New email:
PHP Version: OS:

 

 [2005-07-07 08:26 UTC] narender at classicinformatics dot com
Description:
------------
[root@classicldserver intdld]# pear install pdflib
downloading pdflib-2.0.4.tgz ...
Starting to download pdflib-2.0.4.tgz (36,082 bytes)
..........done: 36,082 bytes
7 source files, building
running: phpize
egrep: /usr/local/include/php/main/php.h: No such file or directory
egrep: /usr/local/include/php/Zend/zend_modules.h: No such file or directory
egrep: /usr/local/include/php/Zend/zend_extensions.h: No such file or directory
Configuring for:
PHP Api Version:
Zend Module Api No:
Zend Extension Api No:
/usr/share/aclocal/vorbis.m4:9: warning: underquoted definition of XIPH_PATH_VORBIS
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending%20aclocal
/usr/share/aclocal/pkg.m4:5: warning: underquoted definition of PKG_CHECK_MODULES
/usr/share/aclocal/pilot-link.m4:1: warning: underquoted definition of AC_PILOT_LINK_HOOK
/usr/share/aclocal/ogg.m4:8: warning: underquoted definition of XIPH_PATH_OGG
/usr/share/aclocal/libmikmod.m4:11: warning: underquoted definition of AM_PATH_LIBMIKMOD
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition of AM_PATH_AUDIOFILE
path to pdflib installation? : /usr/
building in /var/tmp/pear-build-root/pdflib-2.0.4
running: /tmp/tmpgXqqZ7/pdflib-2.0.4/configure --with-pdflib=/usr/
/bin/sh /var/tmp/pear-build-root/pdflib-2.0.4/libtool --mode=compile gcc  -I. -I/tmp/tmpgXqqZ7/pdflib-2.0.4 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/pdflib-2.0.4/include -I/var/tmp/pear-build-root/pdflib-2.0.4/main -I/tmp/tmpgXqqZ7/pdflib-2.0.4 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr//include  -DHAVE_CONFIG_H  -g -O2   -c /tmp/tmpgXqqZ7/pdflib-2.0.4/pdf.c -o pdf.lo
gcc -I. -I/tmp/tmpgXqqZ7/pdflib-2.0.4 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/pdflib-2.0.4/include -I/var/tmp/pear-build-root/pdflib-2.0.4/main -I/tmp/tmpgXqqZ7/pdflib-2.0.4 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr//include -DHAVE_CONFIG_H -g -O2 -c /tmp/tmpgXqqZ7/pdflib-2.0.4/pdf.c  -fPIC -DPIC -o pdf.lo
/bin/sh /var/tmp/pear-build-root/pdflib-2.0.4/libtool --mode=link gcc -DPHP_ATOM_INC -I/var/tmp/pear-build-root/pdflib-2.0.4/include -I/var/tmp/pear-build-root/pdflib-2.0.4/main -I/tmp/tmpgXqqZ7/pdflib-2.0.4 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr//include  -DHAVE_CONFIG_H  -g -O2   -o pdf.la -export-dynamic -avoid-version -prefer-pic -module -rpath /var/tmp/pear-build-root/pdflib-2.0.4/modules  pdf.lo -Wl,-rpath,/usr//lib -L/usr//lib -lpdf
mkdir .libs
rm -fr .libs/pdf.la .libs/pdf.* .libs/pdf.*
(cd . && ln -s pdf.lo pdf.o)
gcc -shared  pdf.lo  -L/usr//lib /usr/lib/libpdf.so  -Wl,-rpath -Wl,/usr//lib -Wl,-soname -Wl,pdf.so -o .libs/pdf.so
creating pdf.la
(cd .libs && rm -f pdf.la && ln -s ../pdf.la pdf.la)
/bin/sh /var/tmp/pear-build-root/pdflib-2.0.4/libtool --mode=install cp ./pdf.la /var/tmp/pear-build-root/pdflib-2.0.4/modules
cp ./.libs/pdf.so /var/tmp/pear-build-root/pdflib-2.0.4/modules/pdf.so
cp ./.libs/pdf.lai /var/tmp/pear-build-root/pdflib-2.0.4/modules/pdf.la
PATH="$PATH:/sbin" ldconfig -n /var/tmp/pear-build-root/pdflib-2.0.4/modules
----------------------------------------------------------------------
Libraries have been installed in:
   /var/tmp/pear-build-root/pdflib-2.0.4/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------

Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).

running: make INSTALL_ROOT="/var/tmp/pear-build-root/install-pdflib-2.0.4" install
Installing shared extensions:     /var/tmp/pear-build-root/install-pdflib-2.0.4/usr/lib/20041030/
running: find "/var/tmp/pear-build-root/install-pdflib-2.0.4" -ls
867078    4 drwxr-xr-x   3 root     root         4096 Jul  7 16:49 /var/tmp/pear-build-root/install-pdflib-2.0.4
867082    4 drwxr-xr-x   3 root     root         4096 Jul  7 16:49 /var/tmp/pear-build-root/install-pdflib-2.0.4/usr
867083    4 drwxr-xr-x   3 root     root         4096 Jul  7 16:49 /var/tmp/pear-build-root/install-pdflib-2.0.4/usr/lib
867084    4 drwxr-xr-x   2 root     root         4096 Jul  7 16:49 /var/tmp/pear-build-root/install-pdflib-2.0.4/usr/lib/20041030
2681812  184 -rwxr-xr-x   1 root     root       182978 Jul  7 16:49 /var/tmp/pear-build-root/install-pdflib-2.0.4/usr/lib/20041030/pdf.so

Warning: opendir(/var/tmp/pear-build-root/install-pdflib-2.0.4//usr/local): failed to open dir: No such file or directory in Builder.php on line 162

Build process completed successfully
install ok: pdflib 2.0.4



Expected result:
----------------
pdf.so should at specified path

Actual result:
--------------
>>>>>>>>>>>>>>>>>>>>>
There is no directory like /var/tmp/pear-build-root/install-pdflib-2.0.4

I could not find pdf.so
I do not know, where the pdf.so is put.

Is there any configuration needed before installation?

Please advise...



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-10 09:15 UTC] danielc at analysisandsolutions dot com
First, you entered this a "Bug System" bug, which it's not.
Second, you need to report this problem via PECL's bug system because pdflib is a PECL package.
 
http://pecl.php.net/bugs/report.php?package=pdflib
 [2007-05-27 14:52 UTC] jsandeo at gmail dot com
I had a similar problem. The problem was in the way I configured, built and installed php.
When you configure php prior to building, make sure that he options: --prefix and --exec-prefix both point to the same directory. After building and installing all of the php bundle, make sure you follow any reccomendations (such as removing .pearrc files or adding paths to php_includes variables in php.ini). Also make sure that the extension_dir variable is correctly set in your php.ini file, and that the directory actually exists, and you should be good.

Good luck :)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Dec 04 04:03:34 2021 UTC