php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #56426 struct doesn't support time_t
Submitted: 2005-06-24 07:15 UTC Modified: 2017-04-01 20:08 UTC
From: laurinkus at gmail dot com Assigned:
Status: Wont fix Package: ffi (PECL)
PHP Version: 5.0.3 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: laurinkus at gmail dot com
New email:
PHP Version: OS:

 

 [2005-06-24 07:15 UTC] laurinkus at gmail dot com
Description:
------------
%summary%

Reproduce code:
---------------
struct Rateinfo {
time_t	ctm;            
double	open;           
double	low;            
double	high;           
double	close;          
int vol;
};


Actual result:
--------------
Crash

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-27 15:06 UTC] peter dot waller at gmail dot com
from the MSDN:

time_t long integer Represents time values in mktime and time. TIME.H 

so either redefine your struct

struct Rateinfo {
int	ctm;            
double	open;           
double	low;            
double	high;           
double	close;          
int vol;
};

or alternatively typedef int time_t; - though I have never had any luck getting typedefs to work. wez says he is working on it, maybe he might fix it?

Pete.
 [2017-04-01 20:08 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 20:08 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2004, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jan 18 01:01:22 2020 UTC