php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #56417 svn functions on working copy
Submitted: 2005-06-14 16:48 UTC Modified: 2008-02-10 20:53 UTC
From: maartenvdv at hotmail dot com Assigned:
Status: Closed Package: svn (PECL)
PHP Version: 5.0.3 OS: Fedora core 3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
9 - 3 = ?
Subscribe to this entry?

 
 [2005-06-14 16:48 UTC] maartenvdv at hotmail dot com
Description:
------------
I tried to perform the functions
svn_ls(),
svn_status()

On working copy folders, using the full path. At least through the browser, the file just hangs and nothing is printed.

When I use a file:/// or a http:// path to a repository it works fine.

Reproduce code:
---------------
print_r(svn_ls("/path/to/workingcopy"));

Expected result:
----------------
list of items in folder

Actual result:
--------------
nothing

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-18 00:14 UTC] maartenvdv at hotmail dot com
When I execute in the command line a php file with the following command:

print_r(svn_ls("/path/to/workingcopy"));

I get the following result:

php: subversion/libsvn_subr/path.c:114: svn_path_join: Assertion `is_canonical ( base, blen)' failed.
Abort
 [2005-10-25 00:28 UTC] alan at akbkhome dot com
I'm not sure it supports that at present. 
- changing to a feature request, if someone want to send a patch to add that feature..
 [2008-02-10 20:53 UTC] scottmac@php.net
I can't reproduce this with 0.3.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 03:01:28 2019 UTC