php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56412 config.m4 in pecl/idn-0.1 has two typos that prevent installation
Submitted: 2005-06-08 13:51 UTC Modified: 2005-06-08 14:03 UTC
From: radwin at yahoo-inc dot com Assigned:
Status: Closed Package: idn (PECL)
PHP Version: 4.3.10 OS: FreeBSD 4.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: radwin at yahoo-inc dot com
New email:
PHP Version: OS:

 

 [2005-06-08 13:51 UTC] radwin at yahoo-inc dot com
Description:
------------
There are two errors in config.m4 for idn. One is that it's looking for idn.h instead of idna.h. The other is a typo in the test of the $PHP_IDN variable.

Reproduce code:
---------------
Here is a patch that fixes the problem:

--- config.m4.orig      Wed Jun  8 10:37:21 2005
+++ config.m4   Wed Jun  8 10:37:58 2005
@@ -6,7 +6,7 @@ PHP_ARG_WITH(idn, for idn support,
 
 if test "$PHP_IDN" != "no"; then
   SEARCH_PATH="/usr/local /usr"
-  SEARCH_FOR="/include/idn.h"
+  SEARCH_FOR="/include/idna.h"
   if test -r $PHP_IDN/$SEARCH_FOR; then # path given as parameter
     IDN_DIR=$PHP_IDN
   else
@@ -19,7 +19,7 @@ if test "$PHP_IDN" != "no"; then
     done
   fi
 
-  if test "PHP_IDN" == "no"; then
+  if test "$PHP_IDN" = "no"; then
     AC_MSG_RESULT([not found])
     AC_MSG_ERROR([Please reinstall the GNU libidn distribution])
   fi


Actual result:
--------------
checking for re2c... exit 0;
checking for mawk... no
checking for gawk... no
checking for nawk... nawk
checking for idn support... yes, shared
checking for idn files in default path... test: PHP_IDN: unexpected operator
checking for stringprep_check_version in -lidn... no
configure: error: wrong idn lib version or lib not found
`/home/tmp/tmpy49O4t/idn-0.1/configure --with-idn' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-08 14:03 UTC] schlueter at phpbar dot de
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

Thanks for reminding me. I was quite sure it was fixed in 
the release since it was fixed in CVS for a long time. :-) 
I'll role a release soon.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Aug 22 06:01:27 2019 UTC