php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56409 Dll does not work
Submitted: 2005-06-04 19:40 UTC Modified: 2007-11-29 04:55 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: vincent dot lascaux at centraliens dot net Assigned:
Status: Wont fix Package: rar (PECL)
PHP Version: 5.0.3 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vincent dot lascaux at centraliens dot net
New email:
PHP Version: OS:

 

 [2005-06-04 19:40 UTC] vincent dot lascaux at centraliens dot net
Description:
------------
The php_rar.dll that can be downloaded from http://snaps.php.net/win32/PECL_5_0/ does not appear to be a valid php extension dll.

I tried to inspect it, and it doesn't export any function (while other extensions export a get_module function)

Reproduce code:
---------------
I downloaded and installed the php_rar.dll from snaps.php.net (copied in the extension folder, changed the ini file). 


Expected result:
----------------
It should start and make the rar_* function available

Actual result:
--------------
When I start php,  I get a popup that says "PHP Startup: Invalid library (maybe not a PHP library) 'php_rar.dll'" and this text on the standard output: "PHP Warning:  PHP Startup: Invalid library (maybe not a PHP library) 'php_rar.dll'  in Unknown 
on line 0"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-04 20:28 UTC] wez@php.net
Try the latest snapshots; it should be fixed as of a couple of days ago.
 [2005-06-04 20:41 UTC] vincent dot lascaux at centraliens dot net
I tried this file: http://snaps.php.net/win32/PECL_5_0/php_rar.dll (02-Jun-2005 18:57 128k), and it still does not work with the same symptoms (popup + text) and probably the same reason (still no exported functions)
 [2005-06-27 19:05 UTC] henrik30000 at hotmail dot com
Have you guys solved the problem?
I found this PHP extension today, and it would be really usefull for a script that I?m planning to make.
So please tell me if you have the solution
 [2005-09-06 15:47 UTC] guyr at gfrs dot co dot uk
I have just tried the latest php_rar.dll from the http://snaps.php.net/win32/PECL_5_0/ folder it is dated 02-Jun-2005 18:57 and still does not work. I am getting the same error as reported before. The Dll does not appear to have been updates like the rest of the files in the folder. and the http://snaps.php.net/win32/PECL_5_1/ does not have it either.

Has this dll been ditched? or just not maintained?

Thank you
 [2005-09-06 15:52 UTC] tony2001 at phpclub dot net
I don't have Win32 build environment (and I doubt I'll get it in the nearest future), so I have no idea why the same code works fine on *nix and is fscked up on Win32.
There are too few developers that use Win32 for developing PHP extensions and none of them have time to look into this issue.
If you want it working - feel free to invest some time & knowledge, it would be really appreciated.
 [2005-10-24 10:32 UTC] Rex at benik dot nl
I can't find this dll file anymore on the site. :)
Anyone having time to fix this dll file? :)
 [2005-12-14 13:37 UTC] oh at dear dot com
oh dear.  What a shame.  I dont like the way that PHP coders are biast towards unix.  PHP is an interpreted language which means it will run on any platform that is php compatable.

I suspect the problem is to do with hash values or something.  Its failing before its even started to bother reading the file.  I think someone needs to recompile it and relaunch it on the site cos this is just gay.
 [2007-11-29 04:37 UTC] yktsang01 at gmail dot com
I'm trying to use this extension too on Win32 and getting warning messages when opening the rar file. The php_rar.dll file I used from http://pecl4win.php.net/ext.php/php_rar.dll is dated 2007-08-17 (PHP5.2 version). Since most posts are way back in 2005, does this extension actually exist back then because according to www.php.net the rar_* functions don't have versioning: "(No version information available, might be only in CVS)".
 [2007-11-29 04:55 UTC] tony at daylessday dot org
>I'm trying to use this extension too on Win32 and getting
>warning messages when opening the rar file.

Such as.. ?

>Since most posts are way back in 2005, does this extension
>actually exist

Yes, it does exist.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 20 06:01:26 2020 UTC