php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56390 Broken HTML in PEPr proposals
Submitted: 2005-05-13 03:49 UTC Modified: 2005-09-09 10:33 UTC
From: daniel dot oconnor at gmail dot com Assigned: dufuz (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: daniel dot oconnor at gmail dot com
New email:
PHP Version: OS:

 

 [2005-05-13 03:49 UTC] daniel dot oconnor at gmail dot com
Description:
------------
When pasting a URL directly into a PEPR proposal, HTML is automatically added for line breaks. In some instances, this creates broken HTML, and it breaks the link.



Reproduce code:
---------------
http://pear.php.net/pepr/pepr-proposal-show.php?id=244

Note the foo.html<br
/>

Expected result:
----------------
Working link

Actual result:
--------------
Broken link

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-13 08:02 UTC] helgi at trance dot is
Are you using Text_Wiki or BBCode format in the proposal ?
 [2005-05-13 20:14 UTC] daniel dot oconnor at gmail dot com
No BBCode/special formating at all.

Unformatted text:

"Upcoming.org is a social event calendar, completely driven by people like you. Manage your events, share events with friends and family, and syndicate your calendar to your own site."

Services_Upcoming is a package designed to operate with the existing web services present on Upcoming.org, to create, search through, and manipulate events.

Currently, it fully supports all exposed web service functionality.

Minor issues with documentation, error handling and installation exist, and unit tests need to be done.

See: http://clockwerx.blogspot.com/2005/04/upcomingorg-web-services-client-for.html

Currently under the GPL, but I can relicence it.

Other issues: Upcoming.org is going to be doing a lot of things to their API, so this package might not be considered "stable" for some time.
 [2005-05-13 21:21 UTC] helgi at trance dot is
Actually I was asking what your proposal is congfigured to use, even tho you don't use any in the proposal it self, because proposals are always outputted in BBCode parser way or Text_Wiki, it's up 2 the propser to pick which way.

Because of that I need to know which one your proposal is configured to so I can pinpoint the problem, tho I think it's the BBCode parser.
 [2005-05-13 22:04 UTC] daniel dot oconnor at gmail dot com
Ooops. Default, BBCode. Switching to Wiki makes the problem go away.
 [2005-05-13 23:21 UTC] helgi at trance dot is
Ok great, I'll look into this, iirc it does a silly thing like:

bbcodeparser(nl2br(htmlentities())) or something, which probably is breaking it I guess.

it's tho not a very pressing matter for me since text_wiki makes the problem go away ;-)

Maybe I'll also just wait until text_wiki supports BBCode and fade BBCodeParser code from the site, but thanks for the notice and input, I'll for sure use the test data you gave me when I'll have a look at this.
 [2005-09-09 10:33 UTC] pierre dot php at gmail dot com
This bug has been fixed in CVS.

If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET).

If this was a problem with the pear.php.net website, the change should be live shortly.

Otherwise, the fix will appear in the package's next release.

Thank you for the report and for helping us make PEAR better.

was a wrong nl2br.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jan 16 08:01:24 2021 UTC